summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlake Matheny <jake@gentoo.org>2004-02-11 21:01:18 +0000
committerBlake Matheny <jake@gentoo.org>2004-02-11 21:01:18 +0000
commit700ee4553f88e6379355020cdf0f476a8a0e97e5 (patch)
tree7efbf195d676ac99f485e50e9641ff16fff11be6 /app-admin/cpu
parentVersion bumped. Closes 41104 (diff)
downloadhistorical-700ee4553f88e6379355020cdf0f476a8a0e97e5.tar.gz
historical-700ee4553f88e6379355020cdf0f476a8a0e97e5.tar.bz2
historical-700ee4553f88e6379355020cdf0f476a8a0e97e5.zip
Adding cpu-1.4.3, new digests and metadata.xml
Diffstat (limited to 'app-admin/cpu')
-rw-r--r--app-admin/cpu/ChangeLog9
-rw-r--r--app-admin/cpu/Manifest7
-rw-r--r--app-admin/cpu/cpu-1.4.2-r1.ebuild4
-rw-r--r--app-admin/cpu/cpu-1.4.3.ebuild39
-rw-r--r--app-admin/cpu/files/digest-cpu-1.4.31
-rw-r--r--app-admin/cpu/metadata.xml9
6 files changed, 63 insertions, 6 deletions
diff --git a/app-admin/cpu/ChangeLog b/app-admin/cpu/ChangeLog
index 33c841153616..32e51c58aadd 100644
--- a/app-admin/cpu/ChangeLog
+++ b/app-admin/cpu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/cpu
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/ChangeLog,v 1.6 2004/01/04 04:34:04 robbat2 Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/ChangeLog,v 1.7 2004/02/11 21:01:18 jake Exp $
+
+*cpu-1.4.3 (11 Feb 2004)
+
+ 11 Feb 2004; Blake Matheny <jake@gentoo.org> cpu-1.4.3.ebuild:
+ Version bump. No longer require force install in sbin.
*cpu-1.4.2-r1 (03 Jan 2004)
diff --git a/app-admin/cpu/Manifest b/app-admin/cpu/Manifest
index b71859a43489..a279e787fbc5 100644
--- a/app-admin/cpu/Manifest
+++ b/app-admin/cpu/Manifest
@@ -1,3 +1,6 @@
+MD5 f5427aa1f120c89e85b071db84ff5cee ChangeLog 1198
+MD5 0086af1c64fa4b50f0aa76e3c4ace885 cpu-1.4.3.ebuild 1069
+MD5 d9e52acebd777bc78b0e3f91eaf9d5d0 metadata.xml 249
+MD5 2b0b29ae02e8492402f9fe58cde59f29 cpu-1.4.2-r1.ebuild 1141
MD5 5e8365fbe120902788e48f72e1e18ae9 files/digest-cpu-1.4.2-r1 62
-MD5 1c2bf5c511f556cce0f9fd8d961691dc cpu-1.4.2-r1.ebuild 1143
-MD5 1ee9bd5a8a36117eb57e905ecfe66334 ChangeLog 1052
+MD5 36e1bd5ca62858bcf4b4f058c790b8b3 files/digest-cpu-1.4.3 62
diff --git a/app-admin/cpu/cpu-1.4.2-r1.ebuild b/app-admin/cpu/cpu-1.4.2-r1.ebuild
index 0dbd349cee5a..f6f46b34689b 100644
--- a/app-admin/cpu/cpu-1.4.2-r1.ebuild
+++ b/app-admin/cpu/cpu-1.4.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.4.2-r1.ebuild,v 1.2 2004/01/25 23:29:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.4.2-r1.ebuild,v 1.3 2004/02/11 21:01:18 jake Exp $
DESCRIPTION="LDAP user management tool written in C and loosely based on FreeBSD's pw(8)"
HOMEPAGE="http://cpu.sourceforge.net/"
diff --git a/app-admin/cpu/cpu-1.4.3.ebuild b/app-admin/cpu/cpu-1.4.3.ebuild
new file mode 100644
index 000000000000..9794cf9137f5
--- /dev/null
+++ b/app-admin/cpu/cpu-1.4.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.4.3.ebuild,v 1.1 2004/02/11 21:01:18 jake Exp $
+
+DESCRIPTION="LDAP user management tool written in C and loosely based on FreeBSD's pw(8)"
+HOMEPAGE="http://cpu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cpu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="net-nds/openldap
+ sys-libs/cracklib"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.54"
+
+WANT_AUTOCONF_2_5=1
+
+src_compile() {
+ local myconf
+
+ # provide PASSWD support as well
+ # It's broken in the application at the moment, so lets not...
+ # myconf="${myconf} --with-passwd"
+
+ # Tell it where to find LDAP
+ myconf="${myconf} --with-ldap"
+ # Tell it where to find CRACKLIB
+ myconf="${myconf} --with-libcrack"
+
+ econf ${myconf} || die "Configure failure"
+ emake || die "Make failure"
+}
+
+src_install() {
+ einstall datadir="${D}/usr/share/doc/${PF}" || die "Einstall failure"
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
diff --git a/app-admin/cpu/files/digest-cpu-1.4.3 b/app-admin/cpu/files/digest-cpu-1.4.3
new file mode 100644
index 000000000000..fe963a19a6f4
--- /dev/null
+++ b/app-admin/cpu/files/digest-cpu-1.4.3
@@ -0,0 +1 @@
+MD5 2d128f82261967d41458800752bc943d cpu-1.4.3.tar.bz2 255668
diff --git a/app-admin/cpu/metadata.xml b/app-admin/cpu/metadata.xml
new file mode 100644
index 000000000000..07078d085ce1
--- /dev/null
+++ b/app-admin/cpu/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jake@gentoo.org</email>
+ <name>Blake Matheny</name>
+</maintainer>
+</pkgmetadata>