summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-03-31 21:28:36 +0000
committerThilo Bangert <bangert@gentoo.org>2009-03-31 21:28:36 +0000
commita89dfe35ef218176f127fd2a2f20a5fa472e0174 (patch)
tree727c1a8e234a6be3af704ea0040042f22d744f42 /app-admin/filewatcher/filewatcher-2.4.6.ebuild
parentBump to 0.24 (diff)
downloadhistorical-a89dfe35ef218176f127fd2a2f20a5fa472e0174.tar.gz
historical-a89dfe35ef218176f127fd2a2f20a5fa472e0174.tar.bz2
historical-a89dfe35ef218176f127fd2a2f20a5fa472e0174.zip
version bump - bug #264204
Package-Manager: portage-2.2_rc26/cvs/Linux i686
Diffstat (limited to 'app-admin/filewatcher/filewatcher-2.4.6.ebuild')
-rw-r--r--app-admin/filewatcher/filewatcher-2.4.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/filewatcher/filewatcher-2.4.6.ebuild b/app-admin/filewatcher/filewatcher-2.4.6.ebuild
new file mode 100644
index 000000000000..902686ab5949
--- /dev/null
+++ b/app-admin/filewatcher/filewatcher-2.4.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/filewatcher/filewatcher-2.4.6.ebuild,v 1.1 2009/03/31 21:28:36 bangert Exp $
+
+DESCRIPTION="This is a configuration file control system and IDS"
+HOMEPAGE="http://sourceforge.net/projects/filewatcher/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-perl/MailTools
+ app-text/rcs
+ virtual/mta"
+
+src_install() {
+ keepdir /var/lib/filewatcher /var/lib/filewatcher/archive
+ dosbin filewatcher || die "could not install filewatcher"
+ doman filewatcher.1 || die "could not install filewatcher manpage"
+
+ dodoc Changes README
+
+ insinto /etc
+ doins "${FILESDIR}"/filewatcher.conf || \
+ die "could not install basic filewatcher config"
+}
+
+pkg_postinst() {
+ elog " A basic configuration has been provided in"
+ elog " /etc/filewatcher.conf. It is strongly"
+ elog " recommended that you invoke filewatcher via"
+ elog " crontab."
+ elog
+ elog " 55,25,40 * * * * root /usr/sbin/filewatcher"
+ elog " --config=/etc/filewatcher.conf"
+}