summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2007-08-07 15:36:23 +0000
committerDaniel Drake <dsd@gentoo.org>2007-08-07 15:36:23 +0000
commitb487ac7532323914aa077d7c55ce050831729918 (patch)
tree32c7b5360f67f9e16c856ab212cd3ad62c5ddccb /app-admin/gamin/gamin-0.1.9.ebuild
parentStable on ppc64; bug #187598 (diff)
downloadhistorical-b487ac7532323914aa077d7c55ce050831729918.tar.gz
historical-b487ac7532323914aa077d7c55ce050831729918.tar.bz2
historical-b487ac7532323914aa077d7c55ce050831729918.zip
Version bump, and fix a bug where CFLAGS were being ignored (Arfrever Frehtes Taifersar Arahesis, #178266). x86-fbsd keywords dropped as fbsd patch no longer applies.
Package-Manager: portage-2.1.3.3
Diffstat (limited to 'app-admin/gamin/gamin-0.1.9.ebuild')
-rw-r--r--app-admin/gamin/gamin-0.1.9.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/gamin/gamin-0.1.9.ebuild b/app-admin/gamin/gamin-0.1.9.ebuild
new file mode 100644
index 000000000000..b66e4a7931f6
--- /dev/null
+++ b/app-admin/gamin/gamin-0.1.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.9.ebuild,v 1.1 2007/08/07 15:36:23 dsd Exp $
+
+inherit autotools eutils libtool
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch "${FILESDIR}/${P}-user-cflags.patch"
+
+ # autoconf is required as the user-cflags patch modifies configure.in
+ # however, elibtoolize is also required, so when the above patch is
+ # removed, replace the following call with a call to elibtoolize
+ eautoreconf
+}
+
+src_compile() {
+ econf --disable-debug \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug debug-api) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ dohtml doc/*
+}