summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-08-14 21:36:28 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-08-14 21:36:28 +0000
commitc66d95a6db0e614a2e50fcb44334e3edb88ddc65 (patch)
tree51f93d7900bc2e5b77efec32bf202634f1633ad1 /app-admin/keepassx/keepassx-0.3.3.ebuild
parentVersion bump. (diff)
downloadhistorical-c66d95a6db0e614a2e50fcb44334e3edb88ddc65.tar.gz
historical-c66d95a6db0e614a2e50fcb44334e3edb88ddc65.tar.bz2
historical-c66d95a6db0e614a2e50fcb44334e3edb88ddc65.zip
Version bump. Upstream bugfix release for the twofish encrypted databases problem, bug #233685.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'app-admin/keepassx/keepassx-0.3.3.ebuild')
-rw-r--r--app-admin/keepassx/keepassx-0.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/keepassx/keepassx-0.3.3.ebuild b/app-admin/keepassx/keepassx-0.3.3.ebuild
new file mode 100644
index 000000000000..36fdd9e802bb
--- /dev/null
+++ b/app-admin/keepassx/keepassx-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.3.ebuild,v 1.1 2008/08/14 21:36:28 tgurr Exp $
+
+EAPI="1"
+
+inherit eutils qt4
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions."
+HOMEPAGE="http://keepassx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/keepassx/KeePassX-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+DEPEND="|| ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-xmlpatterns:4 )
+ >=x11-libs/qt-4.3:4 )"
+RDEPEND="${DEPEND}"
+
+QT4_BUILT_WITH_USE_CHECK="zlib"
+
+src_compile() {
+ cd "${S}/src"
+ lrelease src.pro || die "lrelease failed"
+ mv "${S}"/src/translations/*.qm "${S}"/share/keepassx/i18n
+ cd "${S}"
+ use debug && myconf="DEBUG=1"
+ eqmake4 ${PN}.pro PREFIX="${D}/usr" ${myconf} || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc changelog todo
+}