summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-05-15 22:27:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-05-15 22:27:37 +0000
commitf61e4c8efc2fc49624216926d82de804b687599a (patch)
tree67dd41e8fb863b01914d4b036c773b6f3829da6c /app-admin/logrotate/logrotate-3.6.5-r1.ebuild
parentapplied a patch from Wayne Davison to unpack in src_unpack rather than src_co... (diff)
downloadhistorical-f61e4c8efc2fc49624216926d82de804b687599a.tar.gz
historical-f61e4c8efc2fc49624216926d82de804b687599a.tar.bz2
historical-f61e4c8efc2fc49624216926d82de804b687599a.zip
applied a patch from Wayne Davison to unpack in src_unpack rather than src_compile
Diffstat (limited to 'app-admin/logrotate/logrotate-3.6.5-r1.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.6.5-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-admin/logrotate/logrotate-3.6.5-r1.ebuild b/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
index d070f2f491c3..67dee5ae8bab 100644
--- a/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
+++ b/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.6.5-r1.ebuild,v 1.2 2003/05/14 08:28:07 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.6.5-r1.ebuild,v 1.3 2003/05/15 22:27:29 msterret Exp $
IUSE="selinux"
@@ -19,14 +19,18 @@ DEPEND=">=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
-src_compile() {
+src_unpack() {
+ unpack ${PN}_${PV}.orig.tar.gz
+
use selinux && epatch ${DISTDIR}/${P}-2003011510.patch.gz
sed -i \
-e "s:CFLAGS += -g:CFLAGS += -g ${CFLAGS}:" \
-e "/CVSROOT =/d" \
- Makefile || die "sed failed"
+ ${S}/Makefile || die "sed failed"
+}
+src_compile() {
emake || die "emake failed"
}
@@ -49,7 +53,7 @@ pkg_postinst() {
einfo "If you wish to have logrotate e-mail you updates, please"
einfo "emerge net-mail/mailx and configure logrotate in"
einfo "/etc/logrotate.conf appropriately"
- einfo ""
+ einfo
einfo "Additionally, /etc/logrotate.conf may need to be modified"
einfo "for your particular needs. See man logrotate for details."
}