summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-04-05 16:47:19 +0000
committerKevin McCarthy <signals@gentoo.org>2011-04-05 16:47:19 +0000
commita6212782bc2c31bc7f21d4dc164052664a923584 (patch)
treea775146208195663c77ba4fdc0e9784c25f31462 /app-admin/logsentry/logsentry-1.1.1-r1.ebuild
parentUnmask xf86-video-nouveau-0.0.16_pre20110323 as mesa is now libdrm-2.4.24 com... (diff)
downloadhistorical-a6212782bc2c31bc7f21d4dc164052664a923584.tar.gz
historical-a6212782bc2c31bc7f21d4dc164052664a923584.tar.bz2
historical-a6212782bc2c31bc7f21d4dc164052664a923584.zip
Move temp dir from /etc to /var/tmp. #352486
Package-Manager: portage-2.2.0_alpha29/cvs/Linux x86_64
Diffstat (limited to 'app-admin/logsentry/logsentry-1.1.1-r1.ebuild')
-rw-r--r--app-admin/logsentry/logsentry-1.1.1-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/logsentry/logsentry-1.1.1-r1.ebuild b/app-admin/logsentry/logsentry-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..cdbe404b5316
--- /dev/null
+++ b/app-admin/logsentry/logsentry-1.1.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logsentry/logsentry-1.1.1-r1.ebuild,v 1.1 2011/04/05 16:47:19 signals Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="automatically monitor system logs and mail security violations on a periodic basis"
+# Seems that the project has been discontinued by CISCO?
+HOMEPAGE="http://sourceforge.net/projects/sentrytools/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="virtual/mailx"
+
+S="${WORKDIR}"/logcheck-${PV}
+
+src_compile() {
+ einfo "compile and install mixed in the package makefile"
+}
+
+src_install() {
+ dodir /usr/bin /var/tmp/logcheck /etc/logcheck
+ cp systems/linux/logcheck.sh{,.orig}
+ sed -i \
+ -e 's:/usr/local/bin:/usr/bin:' \
+ -e 's:/usr/local/etc:/etc/logcheck:' \
+ -e 's:/etc/logcheck/tmp:/var/tmp/logcheck:' \
+ systems/linux/logcheck.sh || \
+ die "sed logcheck.sh failed"
+ sed -i \
+ -e "s:/usr/local/bin:${D}/usr/bin:" \
+ -e "s:/usr/local/etc:${D}/etc/logcheck:" \
+ -e "s:/etc/logcheck/tmp:/var/tmp/logcheck:" \
+ -e "s:\$(CC):& \$(LDFLAGS):" \
+ Makefile || die "sed Makefile failed"
+ make CC="$(tc-getCC)" CFLAGS="${CFLAGS}" linux || die
+
+ dodoc README* CHANGES CREDITS
+ dodoc systems/linux/README.*
+
+ cat << EOF > "${S}"/logsentry.cron
+#!/bin/sh
+#
+# Uncomment the following if you want
+# logsentry (logcheck) to run hourly
+#
+# this is part of the logsentry package
+#
+#
+
+#/bin/sh /etc/logcheck/logcheck.sh
+EOF
+
+ exeinto /etc/cron.hourly
+ doexe logsentry.cron
+}
+
+pkg_postinst() {
+ elog
+ elog "Uncomment the logcheck line in /etc/cron.hourly/logsentry.cron,"
+ elog "or add directly to root's crontab"
+ elog
+}