summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-05 19:59:07 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-05 19:59:07 +0000
commit47e88ef04182216fa2e1001eabb1ccb9fe8267df (patch)
tree6c1d571faa3df22de6403834e11701c3ea300e35 /app-admin/scotty
parentMarked stable on mips (diff)
downloadhistorical-47e88ef04182216fa2e1001eabb1ccb9fe8267df.tar.gz
historical-47e88ef04182216fa2e1001eabb1ccb9fe8267df.tar.bz2
historical-47e88ef04182216fa2e1001eabb1ccb9fe8267df.zip
Initial import
Diffstat (limited to 'app-admin/scotty')
-rw-r--r--app-admin/scotty/ChangeLog9
-rw-r--r--app-admin/scotty/files/digest-scotty-2.1.111
-rw-r--r--app-admin/scotty/scotty-2.1.11.ebuild47
3 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/scotty/ChangeLog b/app-admin/scotty/ChangeLog
new file mode 100644
index 000000000000..469ecd51b775
--- /dev/null
+++ b/app-admin/scotty/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/scotty
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/scotty/ChangeLog,v 1.1 2003/05/05 19:59:07 aliz Exp $
+
+*scotty-2.1.11 (05 May 2003)
+
+ 05 May 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Initial import. Ebuild submitted by Maurizio Boriani <debauxit@yahoo.it>
+ in #17832.
diff --git a/app-admin/scotty/files/digest-scotty-2.1.11 b/app-admin/scotty/files/digest-scotty-2.1.11
new file mode 100644
index 000000000000..54f3016f91c2
--- /dev/null
+++ b/app-admin/scotty/files/digest-scotty-2.1.11
@@ -0,0 +1 @@
+MD5 11a636f02af5ab50d22f10864fc30ef5 scotty-2.1.11.tar.gz 1381059
diff --git a/app-admin/scotty/scotty-2.1.11.ebuild b/app-admin/scotty/scotty-2.1.11.ebuild
new file mode 100644
index 000000000000..2f5bde1e8f5b
--- /dev/null
+++ b/app-admin/scotty/scotty-2.1.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/scotty/scotty-2.1.11.ebuild,v 1.1 2003/05/05 19:59:07 aliz Exp $
+
+DESCRIPTION="tcl network management extension"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~schoenw/scotty"
+SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/tkined/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+DEPEND="virtual/glibc
+ sys-devel/flex
+ sys-devel/bison
+ dev-lang/perl
+ dev-lang/tcl
+ dev-lang/tk"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ cd ${S}/unix
+ econf || die
+ make || die
+}
+
+src_install() {
+ cd ${S}/unix
+ dodir /usr/share/man
+ TNM_LIBRARY=${D}/usr/lib/tnm${V} \
+ make prefix=${D}/usr \
+ MAN_INSTALL_DIR=${D}/usr/share/man install
+ make prefix=${D}/usr \
+ MAN_INSTALL_DIR=${D}/usr/share/man sinstall
+ cd ${D}/usr/bin
+ perl -p -i -e 's|/.*/image||' ${D}/usr/lib/tnm2.1.11/pkgIndex.tcl
+ perl -p -i -e 's|/.*/image||' ${D}/usr/lib/tkined1.4.11/pkgIndex.tcl
+ ln -s scotty2.1.11 scotty
+ ln -s tkined1.4.11 tkined
+# mv ${D}/usr/share/man/mann ${D}/usr/share/man/man3
+# cd ${D}/usr/share/man/man3
+# for f in `find ./ -name "*.n"`; do
+# echo ${f} `echo ${f}|cut -d. -f2|cut -d/ -f2`
+# mv ${f} `echo ${f}|cut -d. -f2|cut -d/ -f2`.3tnm
+# done
+}
+