summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-11-07 21:33:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-11-07 21:33:06 +0000
commit75a6d35680ce6225987fdcf58d61862c11bbe72a (patch)
tree0de6cdd0186b3dad55b9a86650459d2531f3cb22 /app-admin/syslog-ng/syslog-ng-3.2.5.ebuild
parentAdd AGPL-3, APSL-2, as-is, CPAL-1.0, DB, EUPL-1.1, LPPL-1.3c, NOSA, OFL-1.1, ... (diff)
downloadhistorical-75a6d35680ce6225987fdcf58d61862c11bbe72a.tar.gz
historical-75a6d35680ce6225987fdcf58d61862c11bbe72a.tar.bz2
historical-75a6d35680ce6225987fdcf58d61862c11bbe72a.zip
3.2 series version bump
Package-Manager: portage-2.1.10.11/cvs/Linux i686
Diffstat (limited to 'app-admin/syslog-ng/syslog-ng-3.2.5.ebuild')
-rw-r--r--app-admin/syslog-ng/syslog-ng-3.2.5.ebuild111
1 files changed, 111 insertions, 0 deletions
diff --git a/app-admin/syslog-ng/syslog-ng-3.2.5.ebuild b/app-admin/syslog-ng/syslog-ng-3.2.5.ebuild
new file mode 100644
index 000000000000..9529dd9541bf
--- /dev/null
+++ b/app-admin/syslog-ng/syslog-ng-3.2.5.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-3.2.5.ebuild,v 1.1 2011/11/07 21:33:06 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools fixheadtails eutils multilib
+
+MY_PV=${PV/_/}
+DESCRIPTION="syslog replacement with advanced filtering features"
+HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
+SRC_URI="http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source/syslog-ng_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="caps hardened ipv6 +pcre selinux spoof-source sql ssl static tcpd"
+RESTRICT="test"
+
+LIBS_DEPEND="
+ spoof-source? ( net-libs/libnet )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ !static? ( >=dev-libs/eventlog-0.2.12 )
+ >=dev-libs/glib-2.10.1:2
+ caps? ( sys-libs/libcap )
+ sql? ( >=dev-db/libdbi-0.8.3 )"
+RDEPEND="
+ !static? (
+ pcre? ( dev-libs/libpcre )
+ ${LIBS_DEPEND}
+ )"
+DEPEND="${RDEPEND}
+ ${LIBS_DEPEND}
+ static? ( >=dev-libs/eventlog-0.2.12[static-libs] )
+ dev-util/pkgconfig
+ sys-devel/flex"
+
+src_prepare() {
+ ht_fix_file configure.in
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use static ; then
+ myconf="${myconf} --enable-static-linking"
+ if use pcre ; then
+ ewarn "USE=pcre is incompatible with static linking"
+ myconf="${myconf} --disable-pcre"
+ fi
+ else
+ myconf="${myconf} --enable-dynamic-linking"
+ fi
+ econf \
+ --disable-dependency-tracking \
+ --sysconfdir=/etc/syslog-ng \
+ --localstatedir=/var/lib/misc \
+ --with-pidfile-dir=/var/run \
+ --with-module-dir=/usr/$(get_libdir)/syslog-ng \
+ $(use_enable caps linux-caps) \
+ $(use_enable ipv6) \
+ $(use_enable pcre) \
+ $(use_enable spoof-source) \
+ $(use_enable sql) \
+ $(use_enable ssl) \
+ $(use_enable tcpd tcp-wrapper) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README \
+ contrib/syslog-ng.conf* \
+ contrib/syslog2ng "${FILESDIR}/syslog-ng.conf."*
+
+ # Install default configuration
+ insinto /etc/syslog-ng
+ if use hardened || use selinux ; then
+ newins "${FILESDIR}/syslog-ng.conf.gentoo.hardened.${PV%.*}" syslog-ng.conf || die
+ elif use userland_BSD ; then
+ newins "${FILESDIR}/syslog-ng.conf.gentoo.fbsd.${PV%.*}" syslog-ng.conf || die
+ else
+ newins "${FILESDIR}/syslog-ng.conf.gentoo.${PV%.*}" syslog-ng.conf || die
+ fi
+
+ insinto /etc/logrotate.d
+ # Install snippet for logrotate, which may or may not be installed
+ if use hardened || use selinux ; then
+ newins "${FILESDIR}/syslog-ng.logrotate.hardened" syslog-ng || die
+ else
+ newins "${FILESDIR}/syslog-ng.logrotate" syslog-ng || die
+ fi
+
+ newinitd "${FILESDIR}/syslog-ng.rc6.${PV%%.*}" syslog-ng || die
+ newconfd "${FILESDIR}/syslog-ng.confd" syslog-ng || die
+ keepdir /etc/syslog-ng/patterndb.d
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+}
+
+pkg_postinst() {
+ # bug #355257
+ if ! has_version app-admin/logrotate ; then
+ echo
+ elog "It is highly recommended that app-admin/logrotate be emerged to"
+ elog "manage the log files. ${PN} installs a file in /etc/logrotate.d"
+ elog "for logrotate to use."
+ echo
+ fi
+}