summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-23 01:26:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-23 01:26:34 +0000
commit7ce034252eb8500ae57b935afbf389e0ad2bd9a0 (patch)
tree6aaa298f5301d2e6a7f41ac6b24630eb041e71a1 /app-admin/webmin
parentChanging dependency to gaim-0.76-ish only (diff)
downloadhistorical-7ce034252eb8500ae57b935afbf389e0ad2bd9a0.tar.gz
historical-7ce034252eb8500ae57b935afbf389e0ad2bd9a0.tar.bz2
historical-7ce034252eb8500ae57b935afbf389e0ad2bd9a0.zip
More GRP friendly
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/Manifest2
-rw-r--r--app-admin/webmin/webmin-1.140-r1.ebuild21
2 files changed, 14 insertions, 9 deletions
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 8cd2b2fc659a..1fb2b3531e6b 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -2,7 +2,7 @@ MD5 0f65bf15f4b028483180906cd8f47edc webmin-1.140.ebuild 2021
MD5 e1448effc29a46897c48b774ec52a127 webmin-1.080.ebuild 1760
MD5 f5f16f198582b89165595878bb861c64 webmin-1.130-r1.ebuild 1980
MD5 871a442fb0428ebaeb78601de262b8b5 webmin-1.110.ebuild 1869
-MD5 62428a102745fe15935d41e76835611d webmin-1.140-r1.ebuild 2079
+MD5 80a4ba7b52db56822ecd6f31a478bce7 webmin-1.140-r1.ebuild 2197
MD5 9e6c039895649548be74be466c5ce993 ChangeLog 6397
MD5 3923b6ae9bc25fc124e24e7747c8a802 metadata.xml 226
MD5 805b49679c94953e708f9322cbb11865 files/webmin-gentoo-init 870
diff --git a/app-admin/webmin/webmin-1.140-r1.ebuild b/app-admin/webmin/webmin-1.140-r1.ebuild
index 54d918c28c04..fbb8c8b118ff 100644
--- a/app-admin/webmin/webmin-1.140-r1.ebuild
+++ b/app-admin/webmin/webmin-1.140-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.140-r1.ebuild,v 1.1 2004/04/23 00:56:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.140-r1.ebuild,v 1.2 2004/04/23 01:26:34 eradicator Exp $
inherit eutils
@@ -20,6 +20,14 @@ RDEPEND="dev-lang/perl
ssl? ( dev-perl/Net-SSLeay )
dev-perl/XML-Generator"
+src_unpack() {
+ unpack ${A}
+
+ # Bug #47020
+ cd ${S}/webalizer
+ epatch ${FILESDIR}/${PN}-1.130-webalizer.patch
+}
+
src_install() {
rm -f mount/freebsd-mounts*
rm -f mount/openbsd-mounts*
@@ -33,11 +41,6 @@ src_install() {
mv ${D}/usr/libexec/webmin/openslp/config \
${D}/usr/libexec/webmin/openslp/config-gentoo-linux
- # Bug #47020
- pushd ${D}/usr/libexec/webmin/webalizer
- epatch ${FILESDIR}/${PN}-1.130-webalizer.patch
- popd
-
exeinto /etc/init.d
newexe webmin-gentoo-init webmin
@@ -47,7 +50,6 @@ src_install() {
exeinto /etc/webmin
doexe ${FILESDIR}/uninstall.sh
- use ssl && sed -i 's:ssl=$ssl:ssl=1:' setup.sh
}
pkg_postinst() {
@@ -77,8 +79,11 @@ pkg_postinst() {
# Start if it was running before
/etc/init.d/webmin start
fi
+
+ einfo "Add webmin to your boot-time services with 'rc-update add webmin'."
+ einfo "Point your web browser to http://localhost:10000 to use webmin."
}
pkg_prerm() {
- /etc/init.d/usermin stop >& /dev/null
+ /etc/init.d/webmin stop >& /dev/null
}