summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-04-28 21:22:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-04-28 21:22:21 +0000
commit50172a03e2e79b14e589e60cc7d84e94738cbb58 (patch)
treecddf5388e02fa5f1128f3d227b5aabc5ffac5804 /app-admin/xstow/xstow-0.5.1.ebuild
parentFix ChangeLog syntax. (diff)
downloadhistorical-50172a03e2e79b14e589e60cc7d84e94738cbb58.tar.gz
historical-50172a03e2e79b14e589e60cc7d84e94738cbb58.tar.bz2
historical-50172a03e2e79b14e589e60cc7d84e94738cbb58.zip
Fix building with GCC 4.3 wrt #219633, thanks to Peter Alfredsen. Also fix USE ncurses handling and pass --without-curses instead of --without-ncurses to configure.
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'app-admin/xstow/xstow-0.5.1.ebuild')
-rw-r--r--app-admin/xstow/xstow-0.5.1.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/app-admin/xstow/xstow-0.5.1.ebuild b/app-admin/xstow/xstow-0.5.1.ebuild
index a395dc977e54..e48ce1c62137 100644
--- a/app-admin/xstow/xstow-0.5.1.ebuild
+++ b/app-admin/xstow/xstow-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/xstow-0.5.1.ebuild,v 1.3 2006/08/01 04:35:31 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/xstow-0.5.1.ebuild,v 1.4 2008/04/28 21:22:20 drac Exp $
inherit eutils
@@ -10,18 +10,24 @@ SRC_URI="mirror://sourceforge/xstow/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="ncurses"
-DEPEND="virtual/libc
- ncurses? ( sys-libs/ncurses )"
+DEPEND="ncurses? ( sys-libs/ncurses )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
src_compile() {
- econf `use_with ncurses` || die
- emake || die
+ econf --disable-dependency-tracking $(use_with ncurses curses)
+ emake || die "emake failed."
}
src_install() {
- dodoc README AUTHORS NEWS README TODO ChangeLog
- make DESTDIR=${D} PACKAGE=${P} install || die
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" \
+ install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
}