summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2005-09-28 05:38:18 +0000
committerBrian Harring <ferringb@gentoo.org>2005-09-28 05:38:18 +0000
commitadfc8b8b094f685c55dea31e7b3c087cb4ce4adf (patch)
tree15113360d56a7a1f01cfe5f18711499aa550f28f /app-arch/ppmd/ppmd-9.1_p10.ebuild
parentFixes for bugs 106882 and 106412, stable bump, and new version (diff)
downloadhistorical-adfc8b8b094f685c55dea31e7b3c087cb4ce4adf.tar.gz
historical-adfc8b8b094f685c55dea31e7b3c087cb4ce4adf.tar.bz2
historical-adfc8b8b094f685c55dea31e7b3c087cb4ce4adf.zip
version bump.
Package-Manager: portage-1.524.2.76-cvs ... people who modify their portage.VERSION are tools
Diffstat (limited to 'app-arch/ppmd/ppmd-9.1_p10.ebuild')
-rw-r--r--app-arch/ppmd/ppmd-9.1_p10.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-arch/ppmd/ppmd-9.1_p10.ebuild b/app-arch/ppmd/ppmd-9.1_p10.ebuild
new file mode 100644
index 000000000000..a28bf25cd22f
--- /dev/null
+++ b/app-arch/ppmd/ppmd-9.1_p10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ppmd-9.1_p10.ebuild,v 1.1 2005/09/28 05:38:18 ferringb Exp $
+
+inherit eutils flag-o-matic
+
+PATCHV="${P##*_p}"
+MY_P="${P%%_*}"
+MY_P="${MY_P/-/_}"
+MY_S=${PN}-i1
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="PPM based compressor -- better behaved than bzip2"
+HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/ppmd/"
+SRC_URI="http://http.us.debian.org/debian/pool/main/p/ppmd/${MY_P}.orig.tar.gz
+ http://http.us.debian.org/debian/pool/main/p/ppmd/${MY_P}-${PATCHV}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4
+ app-arch/gzip
+ sys-devel/patch
+ sys-devel/autoconf
+ sys-devel/automake"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${WORKDIR}/${MY_P}-${PATCHV}.diff"
+ epatch "${S}/${MY_P/_/-}/debian/patches"/*.patch
+ mv "${S}/${MY_P/_/-}/Makefile" "${S}" || die "no makefile found"
+ epatch "${FILESDIR}/${PN}-p${PATCHV}-makefile.patch"
+}
+
+src_compile() {
+# replace-flags "-O3" "-O2"
+# see bug #44529 if this starts producing goofy executables
+# if it pops up again, re-enable replace-flags.
+ append-flags "-fno-inline-functions -fno-exceptions -fno-rtti"
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "failed installing"
+ doman "${S}/${MY_P/_/-}/debian/PPMd.1" || die "failed installing manpage"
+ dodoc "${S}/read_me.txt" || die "failed installed readme"
+}