summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-05-23 12:50:23 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-05-23 12:50:23 +0000
commit5fdc8bed446176f6de68e7c315c9ad26057f7e52 (patch)
tree4bc11ce298c69defdda525ed6564371c6109160c /app-crypt/bestcrypt
parentbump! (diff)
downloadhistorical-5fdc8bed446176f6de68e7c315c9ad26057f7e52.tar.gz
historical-5fdc8bed446176f6de68e7c315c9ad26057f7e52.tar.bz2
historical-5fdc8bed446176f6de68e7c315c9ad26057f7e52.zip
version bump
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-crypt/bestcrypt')
-rw-r--r--app-crypt/bestcrypt/ChangeLog8
-rw-r--r--app-crypt/bestcrypt/Manifest17
-rw-r--r--app-crypt/bestcrypt/bestcrypt-1.6_p1.ebuild104
-rw-r--r--app-crypt/bestcrypt/files/bestcrypt-1.6_p1-makefile_fix.patch42
-rw-r--r--app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p12
5 files changed, 170 insertions, 3 deletions
diff --git a/app-crypt/bestcrypt/ChangeLog b/app-crypt/bestcrypt/ChangeLog
index f9ae92a007c1..8cf59783e9dd 100644
--- a/app-crypt/bestcrypt/ChangeLog
+++ b/app-crypt/bestcrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bestcrypt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.29 2005/04/21 17:59:56 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.30 2005/05/23 12:50:22 dragonheart Exp $
+
+*bestcrypt-1.6_p1 (23 May 2005)
+
+ 23 May 2005; Daniel Black <dragonheart@gentoo.org>
+ +files/bestcrypt-1.6_p1-makefile_fix.patch, +bestcrypt-1.6_p1.ebuild:
+ Version bump
21 Apr 2005; Simon Stelling <blubb@gentoo.org> bestcrypt-1.5_p10.ebuild:
stable on amd64
diff --git a/app-crypt/bestcrypt/Manifest b/app-crypt/bestcrypt/Manifest
index 6179a7924137..fe9b7d72e419 100644
--- a/app-crypt/bestcrypt/Manifest
+++ b/app-crypt/bestcrypt/Manifest
@@ -1,7 +1,20 @@
-MD5 f5cb743df6c04c53fdbc6f9ec87458ab ChangeLog 5825
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 720d90493cd6d4e312093a6455f2fe3e ChangeLog 6005
MD5 bf81314335561f76f139d8cf728cfdc1 bestcrypt-1.5_p10.ebuild 2935
MD5 566cf4f89e44670d0aba4a745913d748 metadata.xml 224
+MD5 862dbf3889ddf0ba7f4ba9c6ad144bf6 bestcrypt-1.6_p1.ebuild 2962
+MD5 e4fb0265d55a570daf750fa7c0b8414c files/bestcrypt-1.6_p1-makefile_fix.patch 1367
MD5 063ae0f67213da39ed4dd75a594b3b07 files/bcrypt3 3246
+MD5 dee6aa8c71224187da9fbc2b2a6fc167 files/digest-bestcrypt-1.6_p1 136
+MD5 c9fdd7c76eb3731a6166cc9ff17bf722 files/digest-bestcrypt-1.5_p10 137
MD5 e9585e8f08138f46bdda7b88ddd81cd8 files/bestcrypt-1.5_p10-makefile_fix.patch 1136
MD5 01225cc87eee84cf54232c86b04e8c93 files/bestcrypt.devfs 1673
-MD5 c9fdd7c76eb3731a6166cc9ff17bf722 files/digest-bestcrypt-1.5_p10 137
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCkdGmmdTrptrqvGERAjm+AJ0WZbvp3gKILvevogIogY9EDNZ/RQCgnUiG
+cwj9+VeGxwg+r6aCwAfqM0I=
+=SE3i
+-----END PGP SIGNATURE-----
diff --git a/app-crypt/bestcrypt/bestcrypt-1.6_p1.ebuild b/app-crypt/bestcrypt/bestcrypt-1.6_p1.ebuild
new file mode 100644
index 000000000000..5d3b450c1bb0
--- /dev/null
+++ b/app-crypt/bestcrypt/bestcrypt-1.6_p1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/bestcrypt-1.6_p1.ebuild,v 1.1 2005/05/23 12:50:22 dragonheart Exp $
+
+inherit flag-o-matic eutils linux-mod toolchain-funcs
+
+MY_PN="bcrypt"
+DESCRIPTION="commercially licensed transparent filesystem encryption"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BestCrypt-${PV/_p/-}.tar.gz
+ http://www.carceri.dk/files/bcrypt-rc6-serpent.diff.gz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/linux-sources"
+
+S=${WORKDIR}/bcrypt
+
+#get-version
+MODULE_NAMES="bc(block:${S}/mod)
+ bc_des(block:${S}/mod/des)
+ bc_3des(block:${S}/mod/3des)
+ bc_bf128(block:${S}/mod/bf128)
+ bc_bf448(block:${S}/mod/bf448)
+ bc_blowfish(block:${S}/mod/blowfish)
+ bc_cast(block:${S}/mod/cast)
+ bc_gost(block:${S}/mod/gost)
+ bc_idea(block:${S}/mod/idea)
+ bc_rijn(block:${S}/mod/rijn)
+ bc_serpent(block:${S}/mod/serpent)
+ bc_rc6(block:${S}/mod/rc6)
+ bc_twofish(block:${S}/mod/twofish)"
+
+src_unpack() {
+ unpack BestCrypt-${PV/_p/-}.tar.gz
+ epatch ${FILESDIR}/${P}-makefile_fix.patch
+ cd ${S}
+
+ epatch ${DISTDIR}/bcrypt-rc6-serpent.diff.gz
+}
+
+src_compile() {
+
+ filter-flags -fforce-addr
+
+ emake -C kgsha EXTRA_CXXFLAGS="${CXXFLAGS} -fPIC" || die "library compile failed"
+ emake -C src EXTRA_CFLAGS="${CFLAGS} -I../kgsha256" || die "bctool compile failed"
+
+ # Don't put stack protection in the kernel - it just is bad
+ append-flags -fno-stack-protector-all -fno-stack-protector
+
+ emake -C mod SYMSRC=bc_dev${KV_MAJOR}${KV_MINOR}.c bc_dev.ver EXTRA_CFLAGS="${CFLAGS}" \
+ || die "compile failed"
+
+ emake -C mod OBJS="bc_dev${KV_MAJOR}${KV_MINOR}.o bc_mgr.o" \
+ KERNEL_DIR=${KV_DIR} KEXT=${KV_OBJ} CC=$(tc-getCC) LD=$(tc-getLD) \
+ AS=$(tc-getAS) CPP=$(tc-getCXX) EXTRA_CFLAGS="${CFLAGS}" || die "compile failed"
+ einfo "Modules compiled"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ cd ${S}
+ dodir /etc
+ cp etc/bc.conf ${D}/etc/bc.conf
+
+ dobin bin/bctool
+ insinto /usr/bin
+ for link in bcumount bcformat bcfsck bcnew bcpasswd bcinfo \
+ bclink bcunlink bcmake_hidden bcreencrypt;
+ do
+ dosym bctool /usr/bin/${link}
+ done
+
+
+ doman man/bctool.8
+ newinitd ${FILESDIR}/bcrypt3 bcrypt
+ dodoc README LICENSE HIDDEN_PART
+
+ insinto /etc/devfs.d
+ doins ${FILESDIR}/bestcrypt.devfs
+}
+
+
+pkg_postinst() {
+
+ einfo "If you are using the serpent or rc6 encryption modules and have any problems,"
+ einfo "please submit bugs to http://bugs.gentoo.org because these modules are not part"
+ einfo "of the standard distribution of BestCrypt for Linux released by Jetico."
+ einfo "For more information on these additional modules:"
+ einfo "visit http://www.carceri.dk/index.php?redirect=other_bestcrypt"
+
+ einfo
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+
+ if [ -e "${ROOT}/dev/.devfsd" ]; then
+ killall -HUP devfsd
+ fi
+}
diff --git a/app-crypt/bestcrypt/files/bestcrypt-1.6_p1-makefile_fix.patch b/app-crypt/bestcrypt/files/bestcrypt-1.6_p1-makefile_fix.patch
new file mode 100644
index 000000000000..bdbdbbf887e3
--- /dev/null
+++ b/app-crypt/bestcrypt/files/bestcrypt-1.6_p1-makefile_fix.patch
@@ -0,0 +1,42 @@
+diff -ru /tmp/bcrypt/kgsha/Makefile bcrypt/kgsha/Makefile
+--- /tmp/bcrypt/kgsha/Makefile 2005-05-14 16:50:36.000000000 +1000
++++ bcrypt/kgsha/Makefile 2005-05-23 22:30:00.000000000 +1000
+@@ -20,6 +20,7 @@
+
+ CPP=g++
+ CPPFLAGS = -Wall -Werror -fno-strength-reduce -I../include
++CPPFLAGS += $(EXTRA_CXXFLAGS)
+
+ TARGET = libkgsha.so
+ HEADERS = kg_defs.h kgsha.h kblock.h sha1.h random.h
+diff -ru /tmp/bcrypt/mod/Makefile bcrypt/mod/Makefile
+--- /tmp/bcrypt/mod/Makefile 2005-05-23 22:26:09.000000000 +1000
++++ bcrypt/mod/Makefile 2005-05-23 22:28:52.000000000 +1000
+@@ -101,15 +101,7 @@
+
+ CFLAGS += -I$(CUR_DIR)/../include/ -I$(KERNEL_DIR)/include/
+
+-ifeq ($(ARCH), alpha)
+-CFLAGS += -O2 -pipe -fno-strict-aliasing -fno-common -mno-fp-regs -ffixed-8 -mcpu=ev5
+-else
+-ifeq ($(ARCH), x86_64)
+-CFLAGS += -O2 -fno-strength-reduce -fno-strict-aliasing -mcmodel=kernel
+-else
+-CFLAGS += -O6 -fno-strength-reduce -fno-strict-aliasing
+-endif
+-endif
++CFLAGS += $(EXTRA_CFLAGS)
+
+ LDFLAGS = -d -r
+
+diff -ru /tmp/bcrypt/src/Makefile bcrypt/src/Makefile
+--- /tmp/bcrypt/src/Makefile 2005-05-14 16:53:06.000000000 +1000
++++ bcrypt/src/Makefile 2005-05-23 22:29:31.000000000 +1000
+@@ -24,6 +24,7 @@
+ CFLAGS += -L../lib -I../include/
+ CFLAGS += -Wall -fno-strict-aliasing -g # -O2
+ #CFLAGS += -g -static -O6
++CFLAGS += $(EXTRA_CFLAGS)
+ LDFLAGS = -ldl -lstdc++
+
+ TARGET = bctool
diff --git a/app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1 b/app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1
new file mode 100644
index 000000000000..ca24dfbd286b
--- /dev/null
+++ b/app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1
@@ -0,0 +1,2 @@
+MD5 966088b98018c477438d908ad763056c BestCrypt-1.6-1.tar.gz 194566
+MD5 aa6e1f0e9ee797b409267bdba1f6534e bcrypt-rc6-serpent.diff.gz 5718