summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-02-20 11:20:12 +0000
committerMike Auty <ikelos@gentoo.org>2009-02-20 11:20:12 +0000
commit6d1914659d160af2599133798a699a75165ce501 (patch)
tree3b06f2a987eec5a728dcc94447a5de12280f0ed0 /app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
parentx11-drivers/xf86-video-ati: fix repoman warnings and remove XDPVER cruft (diff)
downloadhistorical-6d1914659d160af2599133798a699a75165ce501.tar.gz
historical-6d1914659d160af2599133798a699a75165ce501.tar.bz2
historical-6d1914659d160af2599133798a699a75165ce501.zip
Add USE flags for the gui and debugging.
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild b/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
new file mode 100644
index 000000000000..1f86ff7130cb
--- /dev/null
+++ b/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild,v 1.1 2009/02/20 11:20:12 ikelos Exp $
+
+inherit eutils
+
+DESCRIPTION="A time-memory-trade-off-cracker"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="qt4 debug"
+
+CDEPEND="dev-libs/openssl
+ net-libs/netwib
+ qt4? ( >=x11-libs/qt-gui-4 )"
+DEPEND="app-arch/unzip
+ >=dev-util/pkgconfig-0.22
+ ${CDEPEND}"
+RDEPEND="app-crypt/ophcrack-tables
+ ${CDEPEND}"
+
+src_compile() {
+ local myconf
+
+ myconf="$(use_enable qt4 gui)"
+ myconf="${myconf} $(use_enable debug)"
+
+ econf ${myconf} || die "Failed to compile"
+ emake || die "Failed to make"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || "Installation failed."
+
+ cd "${S}"
+ newicon src/gui/pixmaps/os.xpm ophcrack.xpm
+ make_desktop_entry "${PN}" OphCrack ophcrack
+}