summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-02-23 22:57:17 +0000
committerSven Wegener <swegener@gentoo.org>2006-02-23 22:57:17 +0000
commit53f08f1c8b84b29d682753cec83b6df0f27f7728 (patch)
tree11b956101263a760e04cb6714c4770426301d196 /app-crypt
parentModular X dependency fix (diff)
downloadhistorical-53f08f1c8b84b29d682753cec83b6df0f27f7728.tar.gz
historical-53f08f1c8b84b29d682753cec83b6df0f27f7728.tar.bz2
historical-53f08f1c8b84b29d682753cec83b6df0f27f7728.zip
touchup the postinst message
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/Manifest12
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2-r3.ebuild23
2 files changed, 14 insertions, 21 deletions
diff --git a/app-crypt/pinentry/Manifest b/app-crypt/pinentry/Manifest
index 3ab861eca8d5..de079839f1bf 100644
--- a/app-crypt/pinentry/Manifest
+++ b/app-crypt/pinentry/Manifest
@@ -22,16 +22,16 @@ SHA256 1e9c7343efc06a4d4143421f4bf3740c30f71ed6ce5011231505e7e911f31548 metadata
MD5 bd4879c422d925ecce8ef6dc7d3d9c11 pinentry-0.7.2-r2.ebuild 1869
RMD160 d50d7287679a99a5a050066a055e94766daa78ec pinentry-0.7.2-r2.ebuild 1869
SHA256 48081544bd89860fe48df7c25937f0228cdb0a0196271cf6b012f7d5d4492985 pinentry-0.7.2-r2.ebuild 1869
-MD5 d6fed2785b2bd3efb59f56de7026bfd7 pinentry-0.7.2-r3.ebuild 2125
-RMD160 a685c9a9e51db6582b09e774e687351ef25b80ac pinentry-0.7.2-r3.ebuild 2125
-SHA256 869a4ca56c9f6622e1304759812bcc392d7b4fbe54df55c1171545d71cc6a811 pinentry-0.7.2-r3.ebuild 2125
+MD5 98b26dcd829ed5ea15c47f9fd6c07988 pinentry-0.7.2-r3.ebuild 2141
+RMD160 966adcb0893879ea61471a51260b4a9f8f823637 pinentry-0.7.2-r3.ebuild 2141
+SHA256 400fcb2f735c1ae2ed902ab53dfe7483b33f2677a349af6255f91f0d13afcf6e pinentry-0.7.2-r3.ebuild 2141
MD5 0807a36278225cc9824f5466b1a0e0e6 pinentry-0.7.2.ebuild 2023
RMD160 edf3dfb26806d79d38059fb6295f5b4e0bebd7d9 pinentry-0.7.2.ebuild 2023
SHA256 cf5fedeac334a77d2ca85f0c04c2bbebda06b39cf6b5ff75b1e72a4d2410786f pinentry-0.7.2.ebuild 2023
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.1 (GNU/Linux)
-iD8DBQFD/jqkI1lqEGTUzyQRAg/qAJ4+GHkK5IPtjfaxu5QJ2PPy4txo0gCggLFU
-oG1mx7CL4em3ExvQStJVgPI=
-=d392
+iD8DBQFD/j3gI1lqEGTUzyQRAtHPAJ9jCtDr846iopJzhlZISgnlFoaOEwCg305l
+CmG6UmOF05j5GiHrIXZV2Nc=
+=t9OE
-----END PGP SIGNATURE-----
diff --git a/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild b/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild
index b00146babae4..f66734c74988 100644
--- a/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild,v 1.1 2006/02/23 22:43:26 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild,v 1.2 2006/02/23 22:57:17 swegener Exp $
inherit flag-o-matic qt3 multilib eutils autotools
@@ -57,21 +57,14 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
-
- if ! use caps; then
- # gtk versions of pinentry refuse to start when suid root
- for x in curses qt
- do
- [ -f "${D}"/usr/bin/pinentry-${x} ] && fperms u+s /usr/bin/pinentry-${x}
- done
- fi
}
pkg_postinst() {
- if ! use caps; then
- einfo "pinentry-curses and pinentry-qt are installed SUID root to make use of"
- einfo "protected memory space. This is needed in order to have a secure place"
- einfo "to store your passphrases, etc. at runtime but may make some sysadmins"
- einfo "nervous."
- fi
+ einfo "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ einfo "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ einfo "The soft resource limit for memory locking specifies the limit an"
+ einfo "unprivileged process may lock into memory. You can also use POSIX"
+ einfo "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ einfo "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ einfo "your users."
}