summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-06-09 18:05:23 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-06-09 18:05:23 +0000
commitd92d6d6785c6fc3a1733698a6704805777f6ce67 (patch)
tree7ecbe3e3a2d8eff7e36024087002970424ca0b6e /app-crypt
parentMask new app-crypt/hmaccalc temporarily. (diff)
downloadhistorical-d92d6d6785c6fc3a1733698a6704805777f6ce67.tar.gz
historical-d92d6d6785c6fc3a1733698a6704805777f6ce67.tar.bz2
historical-d92d6d6785c6fc3a1733698a6704805777f6ce67.zip
Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>. Used for dracut kernel verification support.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/hmaccalc/ChangeLog11
-rw-r--r--app-crypt/hmaccalc/Manifest4
-rw-r--r--app-crypt/hmaccalc/hmaccalc-0.9.12.ebuild30
-rw-r--r--app-crypt/hmaccalc/metadata.xml11
4 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/hmaccalc/ChangeLog b/app-crypt/hmaccalc/ChangeLog
new file mode 100644
index 000000000000..3925448a40ce
--- /dev/null
+++ b/app-crypt/hmaccalc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-crypt/hmaccalc
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/hmaccalc/ChangeLog,v 1.1 2010/06/09 18:05:23 robbat2 Exp $
+
+*hmaccalc-0.9.12 (09 Jun 2010)
+
+ 09 Jun 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +hmaccalc-0.9.12.ebuild, +metadata.xml:
+ Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>. Used for
+ dracut kernel verification support.
+
diff --git a/app-crypt/hmaccalc/Manifest b/app-crypt/hmaccalc/Manifest
new file mode 100644
index 000000000000..23f37826e2c3
--- /dev/null
+++ b/app-crypt/hmaccalc/Manifest
@@ -0,0 +1,4 @@
+DIST hmaccalc-0.9.12.tar.gz 98795 RMD160 a3adfa953740feb213e85bdc01ec0664e18411a5 SHA1 c841dea1108517a831a6879bf52e692f36b4eda6 SHA256 5be00d6e17dcac7e58812c6d1426e46d675e6a134c02df7751ad2d5844bb5028
+EBUILD hmaccalc-0.9.12.ebuild 764 RMD160 b424ec30667ea10af2ead79079007c153ec461d8 SHA1 4aaa1eac416feb91d338b038bd2ebce82b7d82db SHA256 ad3efcc9f9ad1c8fe390ab14078edf871dc5714b87dccbfdb5b755183421345a
+MISC ChangeLog 452 RMD160 c26c2b288b465326b53fcdc0e298265f4c3acbad SHA1 138130cebea12056e36974625d50c5f7761c1632 SHA256 af6e5b06af896bd97d0b1bf4d797d2ca331cffa804e54760672b50ff5833cafc
+MISC metadata.xml 491 RMD160 3a492e747f5c54c87dce7f299fefe0ead474d088 SHA1 4168e19b07c70934f220928d93bbc6786e75229f SHA256 694de6af35ab27d8f67b4ef14dfba024fafce3339c863e9d273068556935d424
diff --git a/app-crypt/hmaccalc/hmaccalc-0.9.12.ebuild b/app-crypt/hmaccalc/hmaccalc-0.9.12.ebuild
new file mode 100644
index 000000000000..a2c12164e189
--- /dev/null
+++ b/app-crypt/hmaccalc/hmaccalc-0.9.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/hmaccalc/hmaccalc-0.9.12.ebuild,v 1.1 2010/06/09 18:05:23 robbat2 Exp $
+
+EAPI=3
+inherit eutils multilib
+
+DESCRIPTION="Tools for computing and checking HMAC values for files"
+HOMEPAGE="https://fedorahosted.org/hmaccalc/"
+SRC_URI="https://fedorahosted.org/released/hmaccalc/hmaccalc-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ sys-devel/prelink"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-sum-directory=/usr/$(get_libdir)/${PN}/ \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README
+}
diff --git a/app-crypt/hmaccalc/metadata.xml b/app-crypt/hmaccalc/metadata.xml
new file mode 100644
index 000000000000..5e29d3c300e6
--- /dev/null
+++ b/app-crypt/hmaccalc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<longdescription>
+hmaccalc can be used to compute HMAC (hash-based message authentication code)
+values for files. An HMAC is similar in concept to a message digest, except in
+that its calculation also incorporates a key which must be known to both the
+party generating the HMAC and the party verifying the HMAC.
+</longdescription>
+</pkgmetadata>