summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-07 13:04:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-07 13:04:20 +0000
commitf41f25af7176917b1f36d95838c72d3b04cb4eb8 (patch)
tree3bd92e8b4a90843517e35850e6cdaac6bd590f0b /app-editors/cooledit/cooledit-3.17.17.ebuild
parentUse mirror://berlios (bug #218657). (diff)
downloadhistorical-f41f25af7176917b1f36d95838c72d3b04cb4eb8.tar.gz
historical-f41f25af7176917b1f36d95838c72d3b04cb4eb8.tar.bz2
historical-f41f25af7176917b1f36d95838c72d3b04cb4eb8.zip
Fix compilation with LDFLAGS -Wl,--as-needed and implicit declarations because of missing string.h and stdlib.h wrt #246879.
Package-Manager: portage-2.1.6_rc3/cvs/Linux 2.6.27.7 i686
Diffstat (limited to 'app-editors/cooledit/cooledit-3.17.17.ebuild')
-rw-r--r--app-editors/cooledit/cooledit-3.17.17.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-editors/cooledit/cooledit-3.17.17.ebuild b/app-editors/cooledit/cooledit-3.17.17.ebuild
index e09424d35eb4..f30cc6589728 100644
--- a/app-editors/cooledit/cooledit-3.17.17.ebuild
+++ b/app-editors/cooledit/cooledit-3.17.17.ebuild
@@ -1,35 +1,41 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.6 2008/03/26 02:03:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.7 2008/12/07 13:04:19 ssuominen Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Cooledit is a full featured multiple window text editor"
HOMEPAGE="http://freshmeat.net/projects/cooledit/"
SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/editors/X/cooledit/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE="nls spell"
+IUSE="nls"
RDEPEND="x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXau
app-text/ispell"
DEPEND="${RDEPEND}
x11-libs/libXpm"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/cooledit-3.17.17-gcc4.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-implicit_declarations.patch
+ eautoreconf
}
src_compile() {
# Fix for bug 40152 (04 Feb 2004 agriffis)
addwrite /dev/ptym/clone:/dev/ptmx
econf $(use_enable nls)
- emake || die "emake failed"
+ emake || die "emake failed."
}
src_install() {
- make install DESTDIR=${D} || die "install failed"
+ emake DESTDIR="${D}" install || die "emake install failed."
}