summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-23 10:38:21 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-23 10:38:21 +0000
commit58ebab2d4b68502c5fa2a9646becbe65ea558653 (patch)
tree8e5ba1e6e3f4f5bb5e267d36cf5a876ccf8f6178 /app-editors/fte
parentAdd missing patch(es) (diff)
downloadhistorical-58ebab2d4b68502c5fa2a9646becbe65ea558653.tar.gz
historical-58ebab2d4b68502c5fa2a9646becbe65ea558653.tar.bz2
historical-58ebab2d4b68502c5fa2a9646becbe65ea558653.zip
mostly dependencies and a working patch
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/files/digest-fte-20010819-r22
-rw-r--r--app-editors/fte/fte-20010819-r2.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/app-editors/fte/files/digest-fte-20010819-r2 b/app-editors/fte/files/digest-fte-20010819-r2
new file mode 100644
index 000000000000..3d609e9b99c3
--- /dev/null
+++ b/app-editors/fte/files/digest-fte-20010819-r2
@@ -0,0 +1,2 @@
+MD5 2dec08301d39c9d914c7bcdcb0323ed1 fte-20010819-src.zip 467059
+MD5 a3af219f8a6b59ce308b04d0846ea72d fte-20010819-common.zip 174902
diff --git a/app-editors/fte/fte-20010819-r2.ebuild b/app-editors/fte/fte-20010819-r2.ebuild
new file mode 100644
index 000000000000..5161488cd0dd
--- /dev/null
+++ b/app-editors/fte/fte-20010819-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r2.ebuild,v 1.1 2002/04/23 10:38:21 spider Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Lightweight text-mode editor"
+
+SRC_URI="http://prdownloads.sourceforge.net/fte/fte-20010819-src.zip
+ http://prdownloads.sourceforge.net/fte/fte-20010819-common.zip"
+
+HOMEPAGE="http://fte.sourceforge.net"
+
+DEPEND="virtual/glibc
+ app-arch/unzip
+ >=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.20 )"
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.20 )"
+
+TARGETS=""
+
+if [ "`use slang`" ] ; then
+ TARGETS="$TARGETS sfte"
+fi
+
+if [ "`use X`" ] ; then
+ TARGETS="$TARGETS xfte"
+fi
+
+if [ "`use gpm`" ] ; then
+ TARGETS="$TARGETS vfte"
+fi
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack fte-20010819-src.zip
+ unpack fte-20010819-common.zip
+
+ mv fte fte-20010819
+
+ cd ${S}; patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+ cp src/fte-unix.mak src/fte-unix.mak.orig
+
+ cat src/fte-unix.mak.orig | \
+ sed "s/@targets@/${TARGETS}/" | \
+ sed "s/@cflags@/${CFLAGS}/" \
+ > src/fte-unix.mak
+}
+
+src_compile() {
+ emake all || die
+
+ cd config
+ ../src/cfte main.fte ../src/system.fterc
+}
+
+src_install () {
+ local files
+ into /usr
+
+ files="${TARGETS} cfte compkeys"
+
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
+
+ dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+
+ dodir etc/fte
+ cp src/system.fterc ${D}/etc/fte/system.fterc
+
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+
+# if [ -a ${D}/usr/bin/xfte ] ; then
+# into /usr/X11R6 ;
+# dobin src/xfte ;
+# rm ${D}/usr/bin/xfte ;
+# fi
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
+}
+