summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-06-19 14:20:12 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-06-19 14:20:12 +0000
commit99c95f057af96e9da19f4a7225e3bda53ec08514 (patch)
tree38127a3d5ed41df789d1bd83a5dda7c44a6ae774 /app-editors/gobby/gobby-0.1.1.ebuild
parent1.1.1 final. (diff)
downloadhistorical-99c95f057af96e9da19f4a7225e3bda53ec08514.tar.gz
historical-99c95f057af96e9da19f4a7225e3bda53ec08514.tar.bz2
historical-99c95f057af96e9da19f4a7225e3bda53ec08514.zip
Moved from app-text/gobby to app-editors/gobby.
Diffstat (limited to 'app-editors/gobby/gobby-0.1.1.ebuild')
-rw-r--r--app-editors/gobby/gobby-0.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/gobby/gobby-0.1.1.ebuild b/app-editors/gobby/gobby-0.1.1.ebuild
new file mode 100644
index 000000000000..bd5ec67891de
--- /dev/null
+++ b/app-editors/gobby/gobby-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.1.1.ebuild,v 1.1 2005/06/19 14:20:12 humpback Exp $
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="gnome"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+DEPEND=">=dev-cpp/gtkmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=net-libs/obby-0.1.0
+ >=dev-cpp/libxmlpp-2.6
+ >=x11-libs/gtksourceview-1.2.0"
+
+src_compile() {
+ econf --with-gtksourceview `use_with gnome` || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}