summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-02-20 16:01:53 +0000
committerJim Ramsay <lack@gentoo.org>2009-02-20 16:01:53 +0000
commit40736e11570551e1a7d49f47c2a54ea9d556b300 (patch)
tree67ef36d04e5921047a315b054bfbf5513af82437 /app-editors/gvim/gvim-7.1.330.ebuild
parentAdded latest patchlevels of 7.0 and 7.1 (diff)
downloadhistorical-40736e11570551e1a7d49f47c2a54ea9d556b300.tar.gz
historical-40736e11570551e1a7d49f47c2a54ea9d556b300.tar.bz2
historical-40736e11570551e1a7d49f47c2a54ea9d556b300.zip
Added latest patchlevels of 7.0 and 7.1
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-editors/gvim/gvim-7.1.330.ebuild')
-rw-r--r--app-editors/gvim/gvim-7.1.330.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-7.1.330.ebuild b/app-editors/gvim/gvim-7.1.330.ebuild
new file mode 100644
index 000000000000..6a3437998db2
--- /dev/null
+++ b/app-editors/gvim/gvim-7.1.330.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.1.330.ebuild,v 1.1 2009/02/20 16:01:53 lack Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r1"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-libs/libXext
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ x11-libs/libXft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? ( x11-libs/libXaw )
+ )
+ )
+ )"