summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-14 02:54:16 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-14 02:54:16 +0000
commitf8a37cc6dc2e1ec3e275da2dc94f6f023b4f755d (patch)
treedde5b9c842c4cb5e959015e2f2dd4034048f99a4 /app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild
parentVersion bumped; bug #77569. Marked 1.4 stable. (diff)
downloadhistorical-f8a37cc6dc2e1ec3e275da2dc94f6f023b4f755d.tar.gz
historical-f8a37cc6dc2e1ec3e275da2dc94f6f023b4f755d.tar.bz2
historical-f8a37cc6dc2e1ec3e275da2dc94f6f023b4f755d.zip
Fixed an error with USE="-X"; bug #75375. Thanks to Matti P. T. Juvonen <gentoo@mpj.iki.fi>.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild')
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild
new file mode 100644
index 000000000000..d7f1b5b22fd6
--- /dev/null
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20040301-r2.ebuild,v 1.1 2005/02/14 02:54:16 usata Exp $
+
+inherit eutils
+
+MY_PV=${PV:2} # 20021205 -> 021205
+
+DESCRIPTION="Jasspa Microemacs"
+HOMEPAGE="http://www.jasspa.com/"
+SRC_URI="http://www.jasspa.com/release_${MY_PV}/jasspa-memacros-${PV}.tar.gz
+ http://www.jasspa.com/release_${MY_PV}/jasspa-mehtml-${PV}.tar.gz
+ http://www.jasspa.com/release_${MY_PV}/jasspa-mesrc-${PV}.tar.gz
+ http://www.jasspa.com/release_${MY_PV}/meicons-extra.tar.gz"
+# http://www.jasspa.com/release_${MY_PV}/me.ehf.gz
+# http://www.jasspa.com/release_${MY_PV}/meicons.tar.gz
+## http://www.jasspa.com/spelling/ls_enus.tar.gz
+## http://www.jasspa.com/release_${MY_PV}/readme.jasspa_gnome
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="X"
+
+DEPEND="virtual/libc
+ sys-libs/ncurses
+ X? ( virtual/x11 )"
+
+S="${WORKDIR}/me${MY_PV}/src"
+
+src_unpack() {
+ unpack jasspa-mesrc-${PV}.tar.gz
+ cd ${T}
+ # everything except jasspa-mesrc
+ unpack ${A/jasspa-mesrc-${PV}.tar.gz/}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-xorg.patch
+}
+
+src_compile() {
+ sed -i "/^COPTIMISE/s/.*/COPTIMISE = ${CFLAGS}/" linux2.gmk
+ local loadpath="~/.jasspa:/usr/share/jasspa/site:/usr/share/jasspa"
+ if use X
+ then
+ ./build -p "$loadpath"
+ else
+ ./build -t c -p "$loadpath"
+ fi
+}
+
+src_install() {
+ dodir /usr/share/jasspa
+ keepdir /usr/share/jasspa/site
+ if use X; then
+ newbin me me32 || die
+ dobin ${FILESDIR}/me || die
+ else
+ dobin mec || die
+ dosym /usr/bin/mec /usr/bin/me
+ fi
+ dodoc ../*.txt ../change.log
+ cp -r ${T}/* ${D}/usr/share/jasspa
+}