summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2004-11-22 13:32:11 +0000
committerTom Knight <tomk@gentoo.org>2004-11-22 13:32:11 +0000
commitdca11a6300d81ae3d4c2e5af48f37332ae855685 (patch)
treef918f226148dc06784eb626e56edc239368b3a2b /app-editors/joe/joe-3.0-r2.ebuild
parentBug #71849 (diff)
downloadhistorical-dca11a6300d81ae3d4c2e5af48f37332ae855685.tar.gz
historical-dca11a6300d81ae3d4c2e5af48f37332ae855685.tar.bz2
historical-dca11a6300d81ae3d4c2e5af48f37332ae855685.zip
Fixed non-critical buffer overflow, closes bug #71129. Changed einstall to make install, closes bug #72023
Diffstat (limited to 'app-editors/joe/joe-3.0-r2.ebuild')
-rw-r--r--app-editors/joe/joe-3.0-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-editors/joe/joe-3.0-r2.ebuild b/app-editors/joe/joe-3.0-r2.ebuild
new file mode 100644
index 000000000000..9e44f9003dd8
--- /dev/null
+++ b/app-editors/joe/joe-3.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.0-r2.ebuild,v 1.1 2004/11/22 13:32:11 tomk Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha mips amd64 ppc64"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+PROVIDE="virtual/editor"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix for non-critical buffer overflow, bug #71129
+ epatch ${FILESDIR}/${P}-overflow.patch || die "epatch failed"
+ # Fix bug #50271 (joe 3.0 documentation doesn't reflect new config file location)
+ sed -e 's:${prefix}/etc/joerc:@sysconfdir@/joe/joerc:' -i joerc.in
+ for i in jmacsrc.in jpicorc.in jstarrc.in rjoerc.in joe.1.in
+ do
+ sed -e 's:@sysconfdir@/:@sysconfdir@/joe/:' -i ${i}
+ done
+ gnuconfig_update
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc ChangeLog HINTS INFO LIST NEWS README README.cvs TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Global configuration has been moved from /etc to /etc/joe."
+ einfo "You should move or remove your old configuration files."
+ echo
+}