summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-01-24 11:49:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-01-24 11:49:20 +0000
commitf953948a7a190b78a2a1df252d3403ab5027f905 (patch)
tree53aae4655a32a59ff42eb354d03f9b75c545593f /app-editors/lpe/lpe-1.2.6.13.ebuild
parentadd new version of app-editors/lpe in slang mask (diff)
downloadhistorical-f953948a7a190b78a2a1df252d3403ab5027f905.tar.gz
historical-f953948a7a190b78a2a1df252d3403ab5027f905.tar.bz2
historical-f953948a7a190b78a2a1df252d3403ab5027f905.zip
Version bump and fix repoman warnings for old versions and make them depend on slang-1.
Package-Manager: portage-2.1.4
Diffstat (limited to 'app-editors/lpe/lpe-1.2.6.13.ebuild')
-rw-r--r--app-editors/lpe/lpe-1.2.6.13.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/lpe/lpe-1.2.6.13.ebuild b/app-editors/lpe/lpe-1.2.6.13.ebuild
new file mode 100644
index 000000000000..0e3cbfb30f96
--- /dev/null
+++ b/app-editors/lpe/lpe-1.2.6.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/lpe-1.2.6.13.ebuild,v 1.1 2008/01/24 11:49:19 drac Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="a lightweight programmers editor"
+HOMEPAGE="http://packages.qa.debian.org/l/lpe.html"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}-0.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=sys-libs/slang-2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-slang-2.patch
+ eautoconf
+}
+
+src_compile() {
+ econf $(use_enable nls)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake libdir="${D}/usr/$(get_libdir)" \
+ prefix="${D}/usr" \
+ datadir="${D}/usr/share" \
+ mandir="${D}/usr/share/man" \
+ infodir="${D}/usr/share/info" \
+ docdir="${D}/usr/share/doc/${PF}" \
+ exdir="${D}/usr/share/doc/${PF}/examples" \
+ install || die "emake install failed."
+ dodoc AUTHORS BUGS Changelog CUSTOMIZE IDEAS MODES NEWS README TODO
+ prepalldocs
+}