summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-03-03 14:59:18 +0000
committerAli Polatel <hawking@gentoo.org>2008-03-03 14:59:18 +0000
commite8457f008c7cf3618d5f887abd3009d891ab5f08 (patch)
treeca0821eea3f85c11fc801530449917b16d9bdb20 /app-editors/vim-core
parentVersion bumped. (diff)
downloadhistorical-e8457f008c7cf3618d5f887abd3009d891ab5f08.tar.gz
historical-e8457f008c7cf3618d5f887abd3009d891ab5f08.tar.bz2
historical-e8457f008c7cf3618d5f887abd3009d891ab5f08.zip
Version bump. Fixes some memory leaks and other bugs.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-editors/vim-core')
-rw-r--r--app-editors/vim-core/ChangeLog7
-rw-r--r--app-editors/vim-core/vim-core-7.1.266.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 7e3ff2f2ed69..d6333ee22c77 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.278 2008/01/09 21:25:35 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.279 2008/03/03 14:57:35 hawking Exp $
+
+*vim-core-7.1.266 (03 Mar 2008)
+
+ 03 Mar 2008; Ali Polatel <hawking@gentoo.org> +vim-core-7.1.266.ebuild:
+ Version bump. Fixes some memory leaks and other bugs.
*vim-core-7.1.213 (09 Jan 2008)
diff --git a/app-editors/vim-core/vim-core-7.1.266.ebuild b/app-editors/vim-core/vim-core-7.1.266.ebuild
new file mode 100644
index 000000000000..364646a8432d
--- /dev/null
+++ b/app-editors/vim-core/vim-core-7.1.266.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-7.1.266.ebuild,v 1.1 2008/03/03 14:57:35 hawking Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+VIMRC_FILE_SUFFIX="-r3"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="${DEPEND}"
+PDEPEND="!livecd? ( app-vim/gentoo-syntax )"