summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-08-30 00:14:10 +0000
committerJim Ramsay <lack@gentoo.org>2012-08-30 00:14:10 +0000
commit6e2c7e439e1f81d7aaa7767b0d70dbbdf0141df3 (patch)
tree63570757018317fa5406b4a605407313ba9dadba /app-editors/vim
parentVersion bump (diff)
downloadhistorical-6e2c7e439e1f81d7aaa7767b0d70dbbdf0141df3.tar.gz
historical-6e2c7e439e1f81d7aaa7767b0d70dbbdf0141df3.tar.bz2
historical-6e2c7e439e1f81d7aaa7767b0d70dbbdf0141df3.zip
Version bump: 7.3.646 is released
Package-Manager: portage-2.1.11.10/cvs/Linux x86_64
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/vim-7.3.646.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 4dce18131eb8..9ba597831b4b 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.417 2012/07/12 13:01:28 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.418 2012/08/30 00:13:35 lack Exp $
+
+*vim-7.3.646 (30 Aug 2012)
+
+ 30 Aug 2012; Jim Ramsay <jim_ramsay@gentoo.org> +vim-7.3.646.ebuild:
+ Version bump: 7.3.646 is released
*vim-7.3.600 (12 Jul 2012)
diff --git a/app-editors/vim/vim-7.3.646.ebuild b/app-editors/vim/vim-7.3.646.ebuild
new file mode 100644
index 000000000000..35c7b4629ab9
--- /dev/null
+++ b/app-editors/vim/vim-7.3.646.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.3.646.ebuild,v 1.1 2012/08/30 00:13:35 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.3-interix-link.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+}