summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2001-12-05 02:22:59 +0000
committerGeert Bevin <gbevin@gentoo.org>2001-12-05 02:22:59 +0000
commit060935bd900b92ecb23ba8308566664e7258974c (patch)
tree1277b7264e8f8f72ca4b4ffac18077fe36f200c3 /app-editors
parentUpgraded to new version. (diff)
downloadhistorical-060935bd900b92ecb23ba8308566664e7258974c.tar.gz
historical-060935bd900b92ecb23ba8308566664e7258974c.tar.bz2
historical-060935bd900b92ecb23ba8308566664e7258974c.zip
Upgraded to new version.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/bluefish-0.6-r1.ebuild49
-rw-r--r--app-editors/bluefish/bluefish-0.7.ebuild47
-rw-r--r--app-editors/bluefish/files/digest-bluefish-0.6-r11
-rw-r--r--app-editors/bluefish/files/digest-bluefish-0.71
4 files changed, 48 insertions, 50 deletions
diff --git a/app-editors/bluefish/bluefish-0.6-r1.ebuild b/app-editors/bluefish/bluefish-0.6-r1.ebuild
deleted file mode 100644
index 9a047f9be26a..000000000000
--- a/app-editors/bluefish/bluefish-0.6-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Grant Goodyear <g2boojum@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.6-r1.ebuild,v 1.3 2001/11/10 02:54:28 hallski Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
-SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
-HOMEPAGE="http://bluefish.openoffice.nl/"
-
-DEPEND=">=x11-libs/gtk+-1.2.10-r4
- >=media-libs/imlib-1.9.10-r1"
-
-src_compile() {
-
- try ./configure --prefix=/usr --host=${CHOST}
- try make
-
-}
-
-src_install () {
-
- mv Makefile Makefile.orig
- sed -e 's/$(datadir)/$(DESTDIR)$(datadir)/' \
- -e 's/$(pkgdatadir)/$(DESTDIR)$(pkgdatadir)/' \
- -e 's/$(pixmapsdir)/$(DESTDIR)$(pixmapsdir)/' \
- Makefile.orig > Makefile
- cd src
- mv Makefile Makefile.orig
- sed -e 's/$(bindir)/$(DESTDIR)$(bindir)/' \
- Makefile.orig > Makefile
- cd ..
- cd po
- mv Makefile Makefile.orig
- sed -e 's/$(datadir)/$(DESTDIR)$(datadir)/' \
- -e 's/$(gnulocaledir)/$(DESTDIR)$(gnulocaledir)/' \
- -e 's/$(localedir)/$(DESTDIR)$(localedir)/' \
- Makefile.orig > Makefile
- cd ..
- cd man
- mv Makefile Makefile.orig
- sed -e 's/$(mandir)/$(DESTDIR)$(mandir)/' \
- Makefile.orig > Makefile
- cd ..
- try make DESTDIR=${D} install
- dodoc ABOUT_NLS AUTHORS BUGS COPYING INSTALL NEWS README TODO
-
-}
-
diff --git a/app-editors/bluefish/bluefish-0.7.ebuild b/app-editors/bluefish/bluefish-0.7.ebuild
new file mode 100644
index 000000000000..bfa7f10fc5ea
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7.ebuild,v 1.1 2001/12/05 02:22:59 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ perl? ( sys-devel/perl )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use perl`" ]
+ then
+ myconf="$myconf --with-perl"
+ fi
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-autocomplet \
+ $myconf || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ makefiles=`find . -name Makefile`
+ for f in $makefiles; do
+ mv $f $f.orig
+ sed -e 's#$(prefix)#$(DESTDIR)$(prefix)#' \
+ -e 's#${prefix}#$(DESTDIR)${prefix}#' \
+ -e 's#/usr/share/pixmaps#$(DESTDIR)$(prefix)/share/pixmaps#' \
+ $f.orig > $f
+ done
+
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING INSTALL NEWS README TODO
+ mv manual ${D}usr/share/doc/${PF}
+}
+
diff --git a/app-editors/bluefish/files/digest-bluefish-0.6-r1 b/app-editors/bluefish/files/digest-bluefish-0.6-r1
deleted file mode 100644
index ca9728e7ac82..000000000000
--- a/app-editors/bluefish/files/digest-bluefish-0.6-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 29b2da00d3bd72d8bd79e1d7f525e02a bluefish-0.6.tar.bz2 684032
diff --git a/app-editors/bluefish/files/digest-bluefish-0.7 b/app-editors/bluefish/files/digest-bluefish-0.7
new file mode 100644
index 000000000000..d4d11c8bec68
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-0.7
@@ -0,0 +1 @@
+MD5 7d4325d96e7c0444fd634ded2ff33e0e bluefish-0.7.tar.bz2 1687552