summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-30 22:42:58 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-30 22:42:58 +0000
commitb3b89f7383cef4ec162d871d480e8a8dc3c905a3 (patch)
tree4395b20eab01f627dbd106b118e6544770ee31ae /app-emacs/apel
parentAdd a patch to make bmon work with newer sysfs that has symlinks for net devi... (diff)
downloadhistorical-b3b89f7383cef4ec162d871d480e8a8dc3c905a3.tar.gz
historical-b3b89f7383cef4ec162d871d480e8a8dc3c905a3.tar.bz2
historical-b3b89f7383cef4ec162d871d480e8a8dc3c905a3.zip
Add prefix keywords, change EAPI to 3.
Package-Manager: portage-2.2_rc62/cvs/Linux i686
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/ChangeLog9
-rw-r--r--app-emacs/apel/apel-10.7-r1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emacs/apel/ChangeLog b/app-emacs/apel/ChangeLog
index eabc449822c3..ae416e7097d1 100644
--- a/app-emacs/apel/ChangeLog
+++ b/app-emacs/apel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/apel
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/ChangeLog,v 1.29 2009/06/06 15:58:03 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/ChangeLog,v 1.30 2010/01/30 22:40:45 ulm Exp $
+
+*apel-10.7-r1 (30 Jan 2010)
+
+ 30 Jan 2010; Ulrich Mueller <ulm@gentoo.org> +apel-10.7-r1.ebuild:
+ Add prefix keywords, change EAPI to 3.
06 Jun 2009; Ulrich Mueller <ulm@gentoo.org> apel-10.7.ebuild:
Fix elog message, bug 272893.
diff --git a/app-emacs/apel/apel-10.7-r1.ebuild b/app-emacs/apel/apel-10.7-r1.ebuild
new file mode 100644
index 000000000000..d1eb8e9b9fdf
--- /dev/null
+++ b/app-emacs/apel/apel-10.7-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/apel-10.7-r1.ebuild,v 1.1 2010/01/30 22:40:45 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs."
+HOMEPAGE="http://cvs.m17n.org/elisp/APEL/"
+SRC_URI="ftp://ftp.jpl.org/pub/elisp/apel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+src_prepare() {
+ cat <<-EOF >> APEL-CFG
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" || die "emake failed"
+}
+
+src_install() {
+ einstall PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" || die "einstall failed"
+
+ elisp-site-file-install "${FILESDIR}/50apel-gentoo.el"
+
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "See the README.en file in /usr/share/doc/${PF} for tips"
+ elog "on how to customize this package."
+ elog "And you need to rebuild packages depending on ${PN}."
+}