summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-10 08:27:58 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-10 08:27:58 +0000
commitcf3315ef32bf0ea070b87f4cb8bb736636fd6133 (patch)
tree31f11e04adbbc07a6da9b803aabef4a6ac1ed5f9 /app-emacs/ruby-mode
parentinitial import. bug 22295 (diff)
downloadhistorical-cf3315ef32bf0ea070b87f4cb8bb736636fd6133.tar.gz
historical-cf3315ef32bf0ea070b87f4cb8bb736636fd6133.tar.bz2
historical-cf3315ef32bf0ea070b87f4cb8bb736636fd6133.zip
initial import. bug 22295
Diffstat (limited to 'app-emacs/ruby-mode')
-rw-r--r--app-emacs/ruby-mode/Manifest3
-rw-r--r--app-emacs/ruby-mode/files/50ruby-mode-gentoo.el9
-rw-r--r--app-emacs/ruby-mode/files/digest-ruby-mode-1.8.01
-rw-r--r--app-emacs/ruby-mode/ruby-mode-1.8.0.ebuild28
4 files changed, 40 insertions, 1 deletions
diff --git a/app-emacs/ruby-mode/Manifest b/app-emacs/ruby-mode/Manifest
index 484ca7006e04..6bd5eebebbe4 100644
--- a/app-emacs/ruby-mode/Manifest
+++ b/app-emacs/ruby-mode/Manifest
@@ -1,3 +1,4 @@
-MD5 97c024ab4aa0f2dd914f6239663d759a ruby-mode-1.8.0.ebuild 707
+MD5 cde35339c96bbbd379a4b9f79b390ebb ruby-mode-1.8.0.ebuild 733
+MD5 4b9c6aec81e739da43b2388ef029b090 ChangeLog 385
MD5 e1c6eac35da8ce7f11bab66795de0b80 files/digest-ruby-mode-1.8.0 63
MD5 a8b4c21b12b53dc9ecab406a17419f77 files/50ruby-mode-gentoo.el 243
diff --git a/app-emacs/ruby-mode/files/50ruby-mode-gentoo.el b/app-emacs/ruby-mode/files/50ruby-mode-gentoo.el
new file mode 100644
index 000000000000..b717db6eb2b6
--- /dev/null
+++ b/app-emacs/ruby-mode/files/50ruby-mode-gentoo.el
@@ -0,0 +1,9 @@
+;;; Ruby-mode site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
+(autoload 'ruby-mode "ruby-mode" "Major mode to edit ruby files." t)
+(setq auto-mode-alist
+ (append '(("\\.rb$" . ruby-mode)) auto-mode-alist))
+
+
diff --git a/app-emacs/ruby-mode/files/digest-ruby-mode-1.8.0 b/app-emacs/ruby-mode/files/digest-ruby-mode-1.8.0
new file mode 100644
index 000000000000..6bc2df5cd820
--- /dev/null
+++ b/app-emacs/ruby-mode/files/digest-ruby-mode-1.8.0
@@ -0,0 +1 @@
+MD5 582a65e52598a4a1e9fce523e16e67d6 ruby-1.8.0.tar.gz 1979070
diff --git a/app-emacs/ruby-mode/ruby-mode-1.8.0.ebuild b/app-emacs/ruby-mode/ruby-mode-1.8.0.ebuild
new file mode 100644
index 000000000000..22b08a8cf8f4
--- /dev/null
+++ b/app-emacs/ruby-mode/ruby-mode-1.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ruby-mode/ruby-mode-1.8.0.ebuild,v 1.1 2003/09/10 08:27:55 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Ruby code"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+DEPEND="virtual/emacs"
+
+SITEFILE=50ruby-mode-gentoo.el
+
+S="${WORKDIR}/ruby-${PV}/misc"
+
+src_compile() {
+ emacs --no-site-file --no-init-file -batch -f batch-byte-compile *.el
+}
+
+src_install() {
+ elisp-install ruby-mode *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}