summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/semi
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/semi')
-rw-r--r--app-emacs/semi/ChangeLog11
-rw-r--r--app-emacs/semi/files/65semi-gentoo.el5
-rw-r--r--app-emacs/semi/files/digest-semi-1.14.41
-rw-r--r--app-emacs/semi/semi-1.14.4.ebuild49
4 files changed, 66 insertions, 0 deletions
diff --git a/app-emacs/semi/ChangeLog b/app-emacs/semi/ChangeLog
new file mode 100644
index 000000000000..f8462e2763d2
--- /dev/null
+++ b/app-emacs/semi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/semi
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semi/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*semi-1.14.4 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ semi-1.14.4.ebuild, files/65semi-gentoo.el,
+ files/digest-semi-1.14.4 :
+
+ Initial import.
diff --git a/app-emacs/semi/files/65semi-gentoo.el b/app-emacs/semi/files/65semi-gentoo.el
new file mode 100644
index 000000000000..df86eab29a21
--- /dev/null
+++ b/app-emacs/semi/files/65semi-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; SEMI site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'mime-setup)
diff --git a/app-emacs/semi/files/digest-semi-1.14.4 b/app-emacs/semi/files/digest-semi-1.14.4
new file mode 100644
index 000000000000..4e118bd1d40b
--- /dev/null
+++ b/app-emacs/semi/files/digest-semi-1.14.4
@@ -0,0 +1 @@
+MD5 a19aafc0cc9553f445f5adf09c7663fd semi-1.14.4.tar.gz 136013
diff --git a/app-emacs/semi/semi-1.14.4.ebuild b/app-emacs/semi/semi-1.14.4.ebuild
new file mode 100644
index 000000000000..f3e1bbdcf86e
--- /dev/null
+++ b/app-emacs/semi/semi-1.14.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semi/semi-1.14.4.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="a library to provide MIME feature for GNU Emacs -- SEMI"
+HOMEPAGE="http://cvs.m17n.org/elisp/SEMI/index.html.ja.iso-2022-jp"
+SRC_URI="ftp://ftp.m17n.org/pub/mule/semi/semi-1.14-for-flim-1.14/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ >=app-emacs/apel-10.3
+ >=app-emacs/flim-1.14.4";
+# >=virtual/flim-1.14
+
+PROVIDE="virtual/semi-1.14.4"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} install || die
+
+ elisp-site-file-install ${FILESDIR}/65semi-gentoo.el
+
+ dodoc README* Changelog VERSION NEWS
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ einfo "Please unmerge another version or variatns, if you installed."
+ einfo "And you need to rebuild packages depending on ${PN}."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}