summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-16 08:47:55 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-16 08:47:55 +0000
commitb660b9ddb65aa455ed27c0c3388a8ebb0b1ef2aa (patch)
tree9da07d44b94bf01335c2f5e460a97e29e4991bbd /app-emacs/yatex/yatex-1.74.ebuild
parentAdded keyword ~amd64. (diff)
downloadhistorical-b660b9ddb65aa455ed27c0c3388a8ebb0b1ef2aa.tar.gz
historical-b660b9ddb65aa455ed27c0c3388a8ebb0b1ef2aa.tar.bz2
historical-b660b9ddb65aa455ed27c0c3388a8ebb0b1ef2aa.zip
Version bump.
Package-Manager: portage-2.2_rc46/cvs/Linux i686
Diffstat (limited to 'app-emacs/yatex/yatex-1.74.ebuild')
-rw-r--r--app-emacs/yatex/yatex-1.74.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/yatex/yatex-1.74.ebuild b/app-emacs/yatex/yatex-1.74.ebuild
new file mode 100644
index 000000000000..fd8365c6ea1c
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.74.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.74.ebuild,v 1.1 2009/10/16 08:47:55 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.yatex.org/${P/-/}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="as-is"
+IUSE="linguas_ja"
+
+S=${WORKDIR}/${P/-/}
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.73-gentoo.patch"
+}
+
+src_compile() {
+ # byte-compilation fails (as of 1.74): yatexlib.el requires fonts
+ # that are only available under X
+
+ cd docs
+ mv yatexe yatex.info
+ mv yahtmle yahtml.info
+ if use linguas_ja; then
+ iconv -f ISO-2022-JP -t EUC-JP yatexj > yatex-ja.info
+ iconv -f ISO-2022-JP -t EUC-JP yahtmlj > yahtml-ja.info
+ fi
+}
+
+src_install() {
+ elisp-install ${PN} *.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ insinto ${SITEETC}/${PN}
+ doins help/YATEXHLP.eng || die "doins failed"
+
+ doinfo docs/*.info || die "doinfo failed"
+ dodoc docs/*.eng || die "dodoc failed"
+
+ if use linguas_ja; then
+ doins help/YATEXHLP.jp || die "doins failed"
+ dodoc 00readme install docs/{htmlqa,qanda} docs/*.doc \
+ || die "dodoc failed"
+ fi
+}