summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-24 00:57:41 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-24 00:57:41 +0000
commit4e4153d23afb6a0b85108d60c141aad4fc284843 (patch)
tree8a820a2e8ac4ff0f703d8f6590661c5e7dd0c46f /app-emacs
parentFix gcc-4 patch to not break gcc-3 #83047. (diff)
downloadhistorical-4e4153d23afb6a0b85108d60c141aad4fc284843.tar.gz
historical-4e4153d23afb6a0b85108d60c141aad4fc284843.tar.bz2
historical-4e4153d23afb6a0b85108d60c141aad4fc284843.zip
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ecb/ChangeLog7
-rw-r--r--app-emacs/ecb/Manifest10
-rw-r--r--app-emacs/ecb/ecb-2.31.ebuild6
-rw-r--r--app-emacs/ecb/metadata.xml31
4 files changed, 33 insertions, 21 deletions
diff --git a/app-emacs/ecb/ChangeLog b/app-emacs/ecb/ChangeLog
index b8f3b42b6a49..c225e1855b98 100644
--- a/app-emacs/ecb/ChangeLog
+++ b/app-emacs/ecb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ecb
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.15 2005/02/16 17:43:52 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.16 2005/02/24 00:57:41 mkennedy Exp $
+
+ 23 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org> metadata.xml,
+ ecb-2.31.ebuild:
+ Fix missing CEDET make variable binding for case of build against separate
+ CEDET components; Resolves bug 82864
*ecb-2.31 (16 Feb 2005)
diff --git a/app-emacs/ecb/Manifest b/app-emacs/ecb/Manifest
index f7779db85138..464535e836c2 100644
--- a/app-emacs/ecb/Manifest
+++ b/app-emacs/ecb/Manifest
@@ -1,11 +1,11 @@
+MD5 01d04529b18c80b7bfaea508abf6c28b ChangeLog 2816
MD5 4365987c081dad4b484460b807c21deb ecb-2.21.ebuild 1209
-MD5 1e8d66ac0ee51149d97c7eaeb68802b2 ecb-2.31.ebuild 1323
-MD5 06a52b6711c7d25b663c05acfb3f0497 ecb-2.27.ebuild 1372
-MD5 ef6d9aff9c3c7ccb592ae5d5d99f8e62 ChangeLog 2613
-MD5 d66885a4f4fda4d047843a29bc611fa5 metadata.xml 1347
MD5 65b62fd1eff0093edaa05da4947453bc ecb-2.24.ebuild 1257
+MD5 06a52b6711c7d25b663c05acfb3f0497 ecb-2.27.ebuild 1372
+MD5 bd5c148669a0d0853a6099cad65cf0fc ecb-2.31.ebuild 1415
+MD5 6d75917438d32406c49a1b6f350088d5 metadata.xml 1354
+MD5 af9f327c163294046f2addc281abd91f files/70ecb-gentoo.el 88
MD5 55d3c6fd5bb0cfbfea6600fc4340226b files/digest-ecb-2.21 60
MD5 eaf88c4204fa1150d1e9ee41b7c8dd9f files/digest-ecb-2.24 60
MD5 6d1127de5ae48c2d2092034ecd59f58c files/digest-ecb-2.27 60
MD5 0b8c1a7b616d52c17714d0278ef04945 files/digest-ecb-2.31 60
-MD5 af9f327c163294046f2addc281abd91f files/70ecb-gentoo.el 88
diff --git a/app-emacs/ecb/ecb-2.31.ebuild b/app-emacs/ecb/ecb-2.31.ebuild
index fae4fe5006f5..ae9de5c68877 100644
--- a/app-emacs/ecb/ecb-2.31.ebuild
+++ b/app-emacs/ecb/ecb-2.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-2.31.ebuild,v 1.1 2005/02/16 17:43:52 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-2.31.ebuild,v 1.2 2005/02/24 00:57:41 mkennedy Exp $
inherit elisp
@@ -34,10 +34,12 @@ src_compile() {
fi
if has_version "app-emacs/cedet"; then
+ einfo "Building with CEDET"
make CEDET=${SITELISP}/cedet LOADPATH="${loadpath}" || die
else
+ einfo "Building with SEMANTIC, EIEIO and SPEEDBAR"
make SEMANTIC=${SITELISP}/semantic EIEIO=${SITELISP}/eieio \
- SPEEDBAR=${SITELISP}/speedbar LOADPATH="${loadpath}" || die
+ SPEEDBAR=${SITELISP}/speedbar CEDET="" LOADPATH="${loadpath}" || die
fi
}
diff --git a/app-emacs/ecb/metadata.xml b/app-emacs/ecb/metadata.xml
index a56436a14d98..17468753f05f 100644
--- a/app-emacs/ecb/metadata.xml
+++ b/app-emacs/ecb/metadata.xml
@@ -3,27 +3,32 @@
<pkgmetadata>
<herd>emacs</herd>
<longdescription>
-ECB stands for "Emacs Code Browser". While Emacs already has good editing support for many
-modes, its browsing support is somewhat lacking. That's where ECB comes in: it displays a
-number of informational windows that allow for easy source code navigation and overview.
+ECB stands for "Emacs Code Browser". While Emacs already has good editing
+support for many modes, its browsing support is somewhat lacking. That's where
+ECB comes in: it displays a number of informational windows that allow for easy
+source code navigation and overview.
The informational windows can contain:
* A directory tree,
* a list of source files in the current directory,
- * a list of functions/classes/methods/... in the current file, (ECB uses the Semantic
- Bovinator, or Imenu, or etags, for getting this list so all languages supported by any
- of these tools are automatically supported by ECB too)
+
+ * a list of functions/classes/methods/... in the current file, (ECB uses the
+ Semantic Bovinator, or Imenu, or etags, for getting this list so all
+ languages supported by any of these tools are automatically supported by ECB
+ too)
+
* a history of recently visited files,
* the Speedbar and
- * output from compilation (the compilation window) and other modes like help, grep
- etc. or whatever a user defines to be displayed in this window.
-As an added bonus, ECB makes sure to keep these informational windows visible, even when
-you use C-x 1 and similar commands.
+ * output from compilation (the compilation window) and other modes like help,
+ grep etc. or whatever a user defines to be displayed in this window.
+
+As an added bonus, ECB makes sure to keep these informational windows visible,
+even when you use C-x 1 and similar commands.
-It goes without saying that you can configure the layout, ie. which informational windows
-should be displayed where. ECB comes with a number of ready-made window layouts to choose
-from.
+It goes without saying that you can configure the layout, ie. which
+informational windows should be displayed where. ECB comes with a number of
+ready-made window layouts to choose from.
</longdescription>
</pkgmetadata>