summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-12 23:03:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-12 23:03:15 +0000
commit2b408373b0a8b7ed788e9439f4de51d378d0144b (patch)
tree3771bd8b0f72191c8a86160815baaab2d3a6788c /app-emulation/cedega
parentVersion bump. (diff)
downloadhistorical-2b408373b0a8b7ed788e9439f4de51d378d0144b.tar.gz
historical-2b408373b0a8b7ed788e9439f4de51d378d0144b.tar.bz2
historical-2b408373b0a8b7ed788e9439f4de51d378d0144b.zip
Version bump #102184 by Jose Marino.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-emulation/cedega')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/Manifest10
-rw-r--r--app-emulation/cedega/cedega-4.4.1.ebuild54
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.4.11
4 files changed, 71 insertions, 1 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index f03013a8abf3..bcd59fef3c0c 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.15 2005/07/14 00:45:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.16 2005/08/12 23:03:15 vapier Exp $
+
+*cedega-4.4.1 (12 Aug 2005)
+
+ 12 Aug 2005; Mike Frysinger <vapier@gentoo.org> +cedega-4.4.1.ebuild:
+ Version bump #102184 by Jose Marino.
*cedega-4.4 (14 Jul 2005)
diff --git a/app-emulation/cedega/Manifest b/app-emulation/cedega/Manifest
index 0144e0258b39..8f0cf9f27b5b 100644
--- a/app-emulation/cedega/Manifest
+++ b/app-emulation/cedega/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 ba7567a009d7d89f1a4cccf6a0c840af cedega-4.4.ebuild 1923
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 7b1c828d8c9a9cca5440fa70caea5680 cedega-4.0.ebuild 1905
@@ -22,3 +25,10 @@ MD5 6f2852701a274200e814a6412c9b52e9 files/digest-cedega-4.2-r1 75
MD5 072ec142c269f7fb3c0d9add36d905eb files/digest-cedega-4.2.1 69
MD5 0ec2c4d5f2aa15fadf20a22ae70f6188 files/digest-cedega-4.0.1 69
MD5 076b966c6ab4b5f76ea6ca54b81abeac files/digest-cedega-4.3.1 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFC/SregIKl8Uu19MoRAqu3AJwOX5fZxM6a+8ShSJ6ZeiR7Dsx1sACfYVtO
+thD+r3YLUs7zrwQtmIegleU=
+=ZIyT
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/cedega/cedega-4.4.1.ebuild b/app-emulation/cedega/cedega-4.4.1.ebuild
new file mode 100644
index 000000000000..e7890222d1ed
--- /dev/null
+++ b/app-emulation/cedega/cedega-4.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.4.1.ebuild,v 1.1 2005/08/12 23:03:15 vapier Exp $
+
+MY_P="cedega_${PV}-1.i386"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-4.4.1 b/app-emulation/cedega/files/digest-cedega-4.4.1
new file mode 100644
index 000000000000..cc6c4e43adb9
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-4.4.1
@@ -0,0 +1 @@
+MD5 56657272c8daa44c9bdcc5291d206291 cedega_4.4.1-1.i386.tgz 7651120