summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-27 22:37:58 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-27 22:37:58 +0000
commit319a736cb6a38c1b94c0d7bd3c1715f79e7a1f06 (patch)
tree23d399afcb11e5f8ac831a750f7504ad9a3d6e51 /app-emulation/dosemu
parentFixed invalid digest (diff)
downloadhistorical-319a736cb6a38c1b94c0d7bd3c1715f79e7a1f06.tar.gz
historical-319a736cb6a38c1b94c0d7bd3c1715f79e7a1f06.tar.bz2
historical-319a736cb6a38c1b94c0d7bd3c1715f79e7a1f06.zip
Fixes #3067
Diffstat (limited to 'app-emulation/dosemu')
-rw-r--r--app-emulation/dosemu/ChangeLog15
-rw-r--r--app-emulation/dosemu/dosemu-1.1.3-r1.ebuild63
-rw-r--r--app-emulation/dosemu/files/digest-dosemu-1.1.3-r12
3 files changed, 78 insertions, 2 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index 59e4fcf17f71..878b5a38525a 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,8 +1,19 @@
# ChangeLog for app-emulation/dosemu
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.1 2002/05/18 20:14:45 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.2 2002/05/27 22:37:58 rphillips Exp $
-*dosemu-1.1.3, (18 May 2002)
+*dosemu-1.1.3-r1 (27 May 2002)
+
+ 27 May 2002; Ryan Phillips <rphillips@gentoo.org> dosemu-1.1.3-r1.ebuild :
+
+ 1. add/fix manpage installation to /usr/share/man/man1
+ 2. enable mitsumi extentions, previously disabled due to compile errors
+ 3. enable compiletime 'experimental options' for ASPI and Mousedev support
+ 4. fix small typo and remove unnessacery make/make install stubs
+
+ Fixes #3067. Thanks Phillip.
+
+*dosemu-1.1.3 (18 May 2002)
18 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
diff --git a/app-emulation/dosemu/dosemu-1.1.3-r1.ebuild b/app-emulation/dosemu/dosemu-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..1c74e1265369
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.1.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Phillip Lemon (AITD) <plemon@gwi.net>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.1.3-r1.ebuild,v 1.1 2002/05/27 22:37:58 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="DOSEmu 1.1.3 (Developer)"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/dosemu/dosemu-freedos-bin.tgz
+ http://telia.dl.sourceforge.net/sourceforge/dosemu/dosemu-1.1.3.tgz"
+HOMEPAGE="http://www.dosemu.org"
+LICENSE="GPL | LGPL"
+DEPEND="X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+
+src_compile() {
+
+### We make base-configure executable here, so that we can pretend its our
+### ./configure script, by passing it cli arguments, we bypass the usual
+### DOSemu installation script routines :)
+
+ chmod +x $S/base-configure
+
+ local myflags
+
+### mitshm will bork ./base-configure entirely, so we disable it here
+ myflags="--enable-mitshm=yes"
+ myflags="${myflags} --enable-experimental"
+
+### and then set build paramaters based on USE variables
+ use X || myflags="${myflags} --with-x=no"
+ use svga && myflags="${myflags} --enable-use-svgalib"
+
+### this is really a ./configure (honestly)
+ ./base-configure \
+ ${myflags} || die "DOSemu Base Configuration Failed"
+
+### We HAVE to do this, or the build will fail due to strange additional
+### files in the downloaded tarball!
+ emake pristine || die "Dosemu Make Pristine Failed"
+
+### Ok, the build tree is clean, lets make the executables, and 'dos' commands
+ emake -C src || die "DOSemu Make Failed!"
+ emake dosbin || die "DOSbin Make Failed"
+}
+
+src_install () {
+
+### There is no 'make install' for DOSemu, just a set of install scripts
+### We'll pass our portage image directory as the fs root, and 'install'
+### as normal, this seems to stick with the usual gentoo standards
+
+ ./install_systemwide -fd /usr/portage/distfiles/dosemu-freedos-bin.tgz -r /var/tmp/portage/${PF}/image
+
+### install_systemwide doesn't pay attention to our man/info locations
+### we'll install them to the correct location with doman now that they've
+### been created and remove them from the new source tree before emerge
+### installs everything to our 'real' filesystem
+
+doman man/*.1
+rm -rf ${D}opt/dosemu/man
+
+}
+
diff --git a/app-emulation/dosemu/files/digest-dosemu-1.1.3-r1 b/app-emulation/dosemu/files/digest-dosemu-1.1.3-r1
new file mode 100644
index 000000000000..8bd5718d3504
--- /dev/null
+++ b/app-emulation/dosemu/files/digest-dosemu-1.1.3-r1
@@ -0,0 +1,2 @@
+MD5 ba5004378e6cacb1f7e5f9155f1ef176 dosemu-freedos-bin.tgz 686855
+MD5 149cbcb26dffaeb8e5dd76581bff0a39 dosemu-1.1.3.tgz 2179015