summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-08-27 19:49:24 +0000
committerPeter Volkov <pva@gentoo.org>2006-08-27 19:49:24 +0000
commit091ded8c1f1f3b0a115f1cdf39806f047e906b58 (patch)
tree89597e8b9b3df7d96a6f6763a520ca064a73a34d /app-emulation/e-uae/files
parent(#141127) acml.h isn't compatible with cblas.h, so don't symlink it as if it ... (diff)
downloadhistorical-091ded8c1f1f3b0a115f1cdf39806f047e906b58.tar.gz
historical-091ded8c1f1f3b0a115f1cdf39806f047e906b58.tar.bz2
historical-091ded8c1f1f3b0a115f1cdf39806f047e906b58.zip
Version bump. This is actually 0.8.29-WIP3 with some additional fixes.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'app-emulation/e-uae/files')
-rw-r--r--app-emulation/e-uae/files/digest-e-uae-0.8.29_pre200608123
-rw-r--r--app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch44
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/e-uae/files/digest-e-uae-0.8.29_pre20060812 b/app-emulation/e-uae/files/digest-e-uae-0.8.29_pre20060812
new file mode 100644
index 000000000000..71b0185227ee
--- /dev/null
+++ b/app-emulation/e-uae/files/digest-e-uae-0.8.29_pre20060812
@@ -0,0 +1,3 @@
+MD5 af6c098c714ea1419a75485a743ee4c2 e-uae-0.8.29-CVS.tar.bz2 1057924
+RMD160 465eb38bd9ff870985e85f45c512051edc40ac8d e-uae-0.8.29-CVS.tar.bz2 1057924
+SHA256 4e8e672217cdf1366c32289d7ade02457fc4973fac8efac692b6d40ad0e601d5 e-uae-0.8.29-CVS.tar.bz2 1057924
diff --git a/app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch b/app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch
new file mode 100644
index 000000000000..530bf8ecdde0
--- /dev/null
+++ b/app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch
@@ -0,0 +1,44 @@
+diff -Naur e-uae-0.8.29-CVS.orig/configure.in e-uae-0.8.29-CVS/configure.in
+--- e-uae-0.8.29-CVS.orig/configure.in 2006-08-12 19:59:38.000000000 +0400
++++ e-uae-0.8.29-CVS/configure.in 2006-08-27 23:09:02.000000000 +0400
+@@ -890,7 +890,19 @@
+ ],
+ AC_MSG_RESULT(yes)
+ X_CFLAGS="$X_CFLAGS -DUSE_XKB"
+- X_EXTRA_LIBS="$X_EXTRA_LIBS -lxkbfile",
++ X_EXTRA_LIBS="$X_EXTRA_LIBS -lxkbfile"
++ xkb_rules_dir_found="no"
++ for xkb_rules_dir in /usr/share/X11/xkb/rules /usr/lib/X11/xkb/rules /usr/X11R6/lib/X11/xkb/rules
++ do
++ if test -d $xkb_rules_dir ; then
++ X_CFLAGS="$X_CFLAGS -DXKB_PATH=\\\"$xkb_rules_dir/\\\""
++ xkb_rules_dir_found="yes"
++ break
++ fi
++ done
++ if test "x$xkb_rules_dir_found" = "xno" ; then
++ AC_MSG_ERROR([[Could not find xkb path.]])
++ fi,
+ AC_MSG_RESULT(no)
+ )
+ LIBS=$TMP_SAVE_LIBS
+@@ -933,6 +945,7 @@
+ GFX_CFLAGS="$X_CFLAGS"
+ GFX_CPPFLAGS="-DSHM_SUPPORT_LINKS=$SHM_SUPPORT_LINKS"
+ GFX_LIBS="$X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS"
++
+ fi
+
+
+diff -Naur e-uae-0.8.29-CVS.orig/src/gfx-x11/x11keys.c e-uae-0.8.29-CVS/src/gfx-x11/x11keys.c
+--- e-uae-0.8.29-CVS.orig/src/gfx-x11/x11keys.c 2006-07-06 08:04:58.000000000 +0400
++++ e-uae-0.8.29-CVS/src/gfx-x11/x11keys.c 2006-08-27 23:07:19.000000000 +0400
+@@ -26,7 +26,7 @@
+ # include <X11/XKBlib.h>
+ # include <X11/extensions/XKBrules.h>
+
+-static const char xkb_rules_path[] = "/usr/X11R6/lib/X11/xkb/rules/";
++static const char xkb_rules_path[] = XKB_PATH;
+
+
+ /*