summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-28 11:28:37 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-28 11:28:37 +0000
commit99fce3b82477f60f7c9d8a4e183a288b6d45af21 (patch)
treeb969fa8bccbd4d2d8fc28c0c1709634547ce32e0 /app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild
parentVersion bump. (diff)
downloadhistorical-99fce3b82477f60f7c9d8a4e183a288b6d45af21.tar.gz
historical-99fce3b82477f60f7c9d8a4e183a288b6d45af21.tar.bz2
historical-99fce3b82477f60f7c9d8a4e183a288b6d45af21.zip
Version bump, drop old.
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild')
-rw-r--r--app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild b/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild
new file mode 100644
index 000000000000..8bec35e8da5d
--- /dev/null
+++ b/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-opengl/emul-linux-x86-opengl-20121028.ebuild,v 1.1 2012/10/28 11:24:42 pacho Exp $
+
+EAPI="4"
+inherit emul-linux-x86
+
+LICENSE="BSD MIT LGPL-3 SGI-B-2.0"
+
+KEYWORDS="-* ~amd64 ~amd64-linux"
+
+DEPEND="app-admin/eselect-opengl
+ >=app-admin/eselect-mesa-0.0.9"
+RDEPEND=">=app-emulation/emul-linux-x86-xlibs-20100611
+ !<app-emulation/emul-linux-x86-xlibs-20100611
+ media-libs/mesa"
+
+src_prepare() {
+ emul-linux-x86_src_prepare
+ rm -f "${S}/usr/lib32/libGL.so" || die
+ rm -f "${S}/usr/lib32/libGL.so.1" || die
+}
+
+pkg_postinst() {
+ # Update GL symlinks
+ eselect opengl set --use-old || die
+ # And the same for mesa (bug #355393)
+ eselect mesa set 32bit --auto || die
+}