summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2009-12-17 17:05:20 +0000
committerLance Albertson <ramereth@gentoo.org>2009-12-17 17:05:20 +0000
commitcb839da1abf62ce57c0c7381eceea1d13efaed13 (patch)
tree8be4c9462c93467868375e6dc4d292f5588439b9 /app-emulation/ganeti/ganeti-1.2.9.ebuild
parentbug #287546, thanks to Engelbert Gruber <grubert@users.sourceforge.net> and M... (diff)
downloadhistorical-cb839da1abf62ce57c0c7381eceea1d13efaed13.tar.gz
historical-cb839da1abf62ce57c0c7381eceea1d13efaed13.tar.bz2
historical-cb839da1abf62ce57c0c7381eceea1d13efaed13.zip
Version bumps for CVE-2009-4261
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/ganeti/ganeti-1.2.9.ebuild')
-rw-r--r--app-emulation/ganeti/ganeti-1.2.9.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/ganeti/ganeti-1.2.9.ebuild b/app-emulation/ganeti/ganeti-1.2.9.ebuild
new file mode 100644
index 000000000000..69fc9293035f
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-1.2.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-1.2.9.ebuild,v 1.1 2009/12/17 17:05:20 ramereth Exp $
+
+NEED_PYTHON=2.4
+
+inherit python autotools eutils
+
+MY_P=${P/_beta/b}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Ganeti is a virtual server management software tool built upon Xen"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=app-emulation/xen-3.0
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/simplejson
+ dev-python/twisted
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ sys-apps/iproute2
+ sys-cluster/drbd
+ sys-fs/lvm2
+ sys-fs/mdadm"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --localstatedir=/var --with-ssh-initscript=/etc/init.d/sshd
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}/ganeti.initd" ganeti
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /srv/ganeti/{os,export}/
+}