summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-17 01:04:55 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-17 01:04:55 +0000
commit7c06c067dc02205278db17db6d4ddce7ae906573 (patch)
treebfa7ed9f085285702fcd25f978ed4b8b5218c18d /app-emulation/uae
parentlintool fix (diff)
downloadhistorical-7c06c067dc02205278db17db6d4ddce7ae906573.tar.gz
historical-7c06c067dc02205278db17db6d4ddce7ae906573.tar.bz2
historical-7c06c067dc02205278db17db6d4ddce7ae906573.zip
lintool fixes + change usage of svgalib to svga
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog8
-rw-r--r--app-emulation/uae/uae-0.8.22.ebuild34
2 files changed, 20 insertions, 22 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 9a83884ee866..1083e0111b65 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for app-emulation/uae
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.1 2002/10/09 22:45:26 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.2 2002/10/17 01:04:55 vapier Exp $
*uae-0.8.22 (9 Oct 2002)
- 9 Oct 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
-
+ 16 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Changed the references to the USE variable 'svgalib' to 'svga'
+
+ 09 Oct 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/app-emulation/uae/uae-0.8.22.ebuild b/app-emulation/uae/uae-0.8.22.ebuild
index 99ef7dec4ab3..106467cd0ec7 100644
--- a/app-emulation/uae/uae-0.8.22.ebuild
+++ b/app-emulation/uae/uae-0.8.22.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.22.ebuild,v 1.1 2002/10/09 22:45:26 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.22.ebuild,v 1.2 2002/10/17 01:04:00 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="An amiga emulator"
HOMEPAGE="http://www.freiburg.linux.de/~uae/"
LICENSE="GPL"
-DEPEND="X? ( virtual/x11 gtk? ( x11-libs/gtk+ ) ) : ( sys-libs/ncurses svgalib? ( media-libs/svgalib ) )
+DEPEND="X? ( virtual/x11 gtk? ( x11-libs/gtk+ ) ) : ( sys-libs/ncurses svga? ( media-libs/svgalib ) )
sdl? media-libs/libsdl"
SRC_URI="ftp://ftp.freiburg.linux.de/pub/uae/sources/develop/${P}.tar.gz"
SLOT="0"
@@ -17,20 +17,17 @@ src_compile() {
local myopt
myopt="";
- if [ `use X` ];
- then
- myopt="--with-x --enable-dga --enable-vidmode\
- --with-sdl --with-sdl-sound --with-sdl-gfx";
-
- use gtk && myopt="$myopt --enable-ui";
- use gtk || myopt="$myopt --disable-ui";
- else
- if [ `use svgalib` ];
- then
- myopt="--with-svgalib";
- else
- myopt="--with-asciiart";
- fi
+ if [ `use X` ]; then
+ myopt="--with-x --enable-dga --enable-vidmode --with-sdl --with-sdl-sound --with-sdl-gfx"
+
+ use gtk && myopt="$myopt --enable-ui"
+ use gtk || myopt="$myopt --disable-ui"
+ else
+ if [ `use svga` ]; then
+ myopt="--with-svgalib";
+ else
+ myopt="--with-asciiart";
+ fi
fi
patch -p0 < ${FILESDIR}/uae-patch.diff
@@ -39,12 +36,12 @@ src_compile() {
--prefix=/usr \
--enable-threads \
--enable-scsi-device \
- ${myopt} || die "./configure failed"
+ ${myopt} || die "./configure failed"
emake || die
}
-src_install () {
+src_install() {
dobin uae readdisk
mv docs/unix/README docs/README.unix
dodoc docs/*
@@ -52,4 +49,3 @@ src_install () {
insinto /usr/share/uae/amiga-tools
doins amiga/{*hack,trans*,uae*}
}
-