summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-07-05 00:16:41 +0000
committerMike Frysinger <vapier@gentoo.org>2011-07-05 00:16:41 +0000
commit7df34b808af2afac7348a15ff211ea676e8ff88b (patch)
tree4aa8c8c640674990214407fc2d8ca283289b5b8f /app-emulation/wine/wine-1.3.15.ebuild
parentVersion bump (diff)
downloadhistorical-7df34b808af2afac7348a15ff211ea676e8ff88b.tar.gz
historical-7df34b808af2afac7348a15ff211ea676e8ff88b.tar.bz2
historical-7df34b808af2afac7348a15ff211ea676e8ff88b.zip
Add USE=opencl support by Fabio Erculiani #367225.
Diffstat (limited to 'app-emulation/wine/wine-1.3.15.ebuild')
-rw-r--r--app-emulation/wine/wine-1.3.15.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.3.15.ebuild b/app-emulation/wine/wine-1.3.15.ebuild
index 722e52398fa1..8b00afcff9a4 100644
--- a/app-emulation/wine/wine-1.3.15.ebuild
+++ b/app-emulation/wine/wine-1.3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.15.ebuild,v 1.2 2011/04/30 06:26:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.15.ebuild,v 1.3 2011/07/05 00:16:41 vapier Exp $
EAPI="2"
@@ -33,7 +33,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jack jpeg lcms ldap mousewarp mp3 nas ncurses nls openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jack jpeg lcms ldap mousewarp mp3 nas ncurses nls openal opencl +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -72,6 +72,7 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
esd? ( media-sound/esound )
nas? ( media-libs/nas )
cups? ( net-print/cups )
+ opencl? ( x11-drivers/nvidia-drivers )
opengl? ( virtual/opengl )
pulseaudio? ( media-sound/pulseaudio )
gsm? ( media-sound/gsm )
@@ -152,6 +153,7 @@ do_configure() {
$(use_with nas) \
$(use_with nls gettextpo) \
$(use_with openal) \
+ $(use_with opencl) \
$(use_with opengl) \
$(use_with ssl openssl) \
$(use_with oss) \