summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-04 06:38:14 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-04 06:38:14 +0000
commit1517454a1ebec462c90f9dfa9aab24955131bfdb (patch)
tree6383076831e1b9538d48df6fa04b2ff1d7df5493 /app-emulation/winesetuptk
parentpspell->aspell dependency (diff)
downloadhistorical-1517454a1ebec462c90f9dfa9aab24955131bfdb.tar.gz
historical-1517454a1ebec462c90f9dfa9aab24955131bfdb.tar.bz2
historical-1517454a1ebec462c90f9dfa9aab24955131bfdb.zip
changed from econf to configure so --sysconfdir does not get specified
multiple times. removed non-needed myconf variable setting as no use variables were referenced for the setting of them.
Diffstat (limited to 'app-emulation/winesetuptk')
-rw-r--r--app-emulation/winesetuptk/ChangeLog11
-rw-r--r--app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild21
2 files changed, 18 insertions, 14 deletions
diff --git a/app-emulation/winesetuptk/ChangeLog b/app-emulation/winesetuptk/ChangeLog
index 03c77a7897d8..62146f1b8aff 100644
--- a/app-emulation/winesetuptk/ChangeLog
+++ b/app-emulation/winesetuptk/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for app-emulation/winesetuptk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.5 2002/08/19 17:47:45 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.6 2002/09/04 06:38:14 raker Exp $
*winesetuptk-0.6.0b-r2 (19 August 2002)
- 19 August 2002; Sascha Schwabbauer <cybersystem@gentoo.org> ChangeLog, winesetuptk-0.6.0b-r2.ebuild :
+ 04 Sep 2002; Nick Hadaway <raker@gentoo.org> winesetuptk-0.6.0b-r2.ebuild :
+ Changed econf to ./configure so there aren't conflicting --sysconfdir
+ arguments. Moved useless setting of myconf variables to configure
+ option list as no use variables were referenced.
+ 19 August 2002; Sascha Schwabbauer <cybersystem@gentoo.org> ChangeLog, winesetuptk-0.6.0b-r2.ebuild :
Added -ppc to the keywords.
*winesetuptk-0.6.0b-r2 (12 Jun 2002)
@@ -16,19 +20,16 @@
12 Jun 2002; Seemant Kulleen <seemant@gentoo.org>
winsetuptk-0.6.0b-r2.ebuild files/digest-winesetuptk-0.6.0b-r2 :
-
Removed wine from RDEPEND, as this package can really run without
wine/winex, though it is useles.
*winesetuptk-0.6.0b-r1 (26 Apr 2002)
26 Apr 2002; Seemant Kulleen <seemant@gentoo.org> winesetuptk-0.6.0b-r1.ebuild :
-
It was pointed out indirectly by a new user that tcl and tk are NOT required
since this package links statically with them. Hooray for de-bloat!
*winesetuptk-0.6.0b (3 Apr 2002)
3 Apr 2002; Seemant Kulleen <seemant@gentoo.org> winesetuptk-0.6.0b.ebuild :
-
New package to help users set up wine on their systems.
diff --git a/app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild b/app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild
index 3fac81384ea9..091ab6b7b922 100644
--- a/app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild
+++ b/app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild,v 1.5 2002/08/19 17:47:45 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/winesetuptk-0.6.0b-r2.ebuild,v 1.6 2002/09/04 06:38:14 raker Exp $
MY_P1=tcltk-${P}
P=${P}
S=${WORKDIR}/${P}
+
DESCRIPTION="Setup tool for WiNE adapted from Codeweavers by Debian"
SRC_URI="http://ftp.debian.org/debian/pool/main/w/winesetuptk/${P/-/_}-1.tar.gz"
HOMEPAGE="http://packages.debian.org/unstable/otherosfs/winesetuptk.html"
@@ -33,17 +34,19 @@ src_compile() {
cd ${S}/${P}
- local myconf
- myconf="${myconf} --with-tcltk=${S}/${MY_P1}"
- myconf="${myconf} --with-launcher=/usr/bin --with-exe=/usr/bin"
- myconf="${myconf} --with-doc=/usr/share/doc/${P}"
-
- econf \
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
--sysconfdir=/etc/wine \
--enable-curses \
- ${myconf} || die
+ --with-tcltk=${S}/${MY_P1} \
+ --with-launcher=/usr/bin \
+ --with-exe=/usr/bin \
+ --with-doc=/usr/share/doc/${P} || die "configure failed"
- make || die
+ make || die "make failed"
}