summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-29 10:55:17 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-29 10:55:17 +0000
commit0b848c0177d19af866d48753d5051820cdf98d06 (patch)
tree4929015a68b5534baa69bbc78088a65f08a13136 /app-emulation/xtrs/files/xtrs-4.9-gentoo.diff
parentnew snapshot (diff)
downloadhistorical-0b848c0177d19af866d48753d5051820cdf98d06.tar.gz
historical-0b848c0177d19af866d48753d5051820cdf98d06.tar.bz2
historical-0b848c0177d19af866d48753d5051820cdf98d06.zip
user submission #2940: emulator for radioshack trs80 with a model 4p rom and ls-dos 6.3
Diffstat (limited to 'app-emulation/xtrs/files/xtrs-4.9-gentoo.diff')
-rw-r--r--app-emulation/xtrs/files/xtrs-4.9-gentoo.diff142
1 files changed, 142 insertions, 0 deletions
diff --git a/app-emulation/xtrs/files/xtrs-4.9-gentoo.diff b/app-emulation/xtrs/files/xtrs-4.9-gentoo.diff
new file mode 100644
index 000000000000..084cf8a6284c
--- /dev/null
+++ b/app-emulation/xtrs/files/xtrs-4.9-gentoo.diff
@@ -0,0 +1,142 @@
+diff -c xtrs-4.9-new/ChangeLog xtrs-4.9/ChangeLog
+*** xtrs-4.9-new/ChangeLog Sat May 11 20:49:32 2002
+--- xtrs-4.9/ChangeLog Wed May 22 15:39:26 2002
+***************
+*** 1,3 ****
+--- 1,9 ----
++ 4.9-Gentoo -- Wed May 22 15:33:01 ECT 2002 Phill Lemon <plemon@gwi.net>
++
++ Patched for gentoo linux 1.1a ebuild distribution
++ Changed default romtype to Model P4 int,5 (main.c). OSS Freeware ROM Image
++ to avoid potential copyright infringement
++
+ 4.9 -- Sat May 11 13:42:06 PDT 2002 Tim Mann <tim@tim-mann.org>
+
+ This release has various bug fixes and tiny features that have
+diff -c xtrs-4.9-new/Makefile.local xtrs-4.9/Makefile.local
+*** xtrs-4.9-new/Makefile.local Fri Aug 31 19:02:05 2001
+--- xtrs-4.9/Makefile.local Wed May 22 15:02:52 2002
+***************
+*** 25,49 ****
+ # is included in this package. This ROM cannot boot a Model III mode
+ # operating system.
+
+! # for -model I
+! BUILT_IN_ROM = fakerom.hex
+! # for -model III and -model 4
+! BUILT_IN_ROM3 = fakerom.hex
+! # for -model 4P
+! BUILT_IN_ROM4P = xtrsrom4p.hex
+
+ # If you would like the application to load a default ROM file at startup
+ # time, use these lines (with the appropriate file names). The default file
+ # name is ignored and can be omitted if the ROM for that model is built in.
+
+! DEFAULT_ROM = -DDEFAULT_ROM='"/usr/local/lib/xtrs/level2rom.hex"' \
+! -DDEFAULT_ROM3='"/usr/local/lib/xtrs/romimage.m3"' \
+! -DDEFAULT_ROM4P='"/usr/local/lib/xtrs/romimage.m4p"'
+
+ # If you would like to change where xtrs looks for disk?-? files, edit
+ # this line. "." of course means the current working directory.
+
+! DISKDIR = -DDISKDIR='"."'
+
+ # If you have the GNU readline package (the README file tells you where to
+ # get it) and would like to use it with the built-in Z-80 debugger, use
+--- 25,49 ----
+ # is included in this package. This ROM cannot boot a Model III mode
+ # operating system.
+
+! ## for -model I
+! #BUILT_IN_ROM = fakerom.hex
+! ## for -model III and -model 4
+! #BUILT_IN_ROM3 = fakerom.hex
+! ## for -model 4P
+! #BUILT_IN_ROM4P = xtrsrom4p.hex
+
+ # If you would like the application to load a default ROM file at startup
+ # time, use these lines (with the appropriate file names). The default file
+ # name is ignored and can be omitted if the ROM for that model is built in.
+
+! DEFAULT_ROM = -DDEFAULT_ROM='"/usr/share/xtrs/fakerom.hex"' \
+! -DDEFAULT_ROM3='"/usr/share/xtrs/fakerom.hex"' \
+! -DDEFAULT_ROM4P='"/usr/share/xtrs/xtrsrom4p.hex"'
+
+ # If you would like to change where xtrs looks for disk?-? files, edit
+ # this line. "." of course means the current working directory.
+
+! DISKDIR = -DDISKDIR='"/usr/share/xtrs/"'
+
+ # If you have the GNU readline package (the README file tells you where to
+ # get it) and would like to use it with the built-in Z-80 debugger, use
+***************
+*** 61,67 ****
+
+ # If you have gcc, and you want to use it:
+
+! #CC = gcc
+
+ # If you need a different path for libraries:
+
+--- 61,67 ----
+
+ # If you have gcc, and you want to use it:
+
+! CC = gcc
+
+ # If you need a different path for libraries:
+
+***************
+*** 89,95 ****
+
+ # prefix directory
+
+! PREFIX=/usr/local
+ #If included in distribution: PREFIX=/usr
+
+ # Set these to where you want installed stuff to go, if you install them.
+--- 89,95 ----
+
+ # prefix directory
+
+! PREFIX=${D}/usr
+ #If included in distribution: PREFIX=/usr
+
+ # Set these to where you want installed stuff to go, if you install them.
+***************
+*** 103,110 ****
+ INSTALL = install
+
+ # If you are building in a subdirectory:
+! #vpath %.c ..
+! #vpath %.h ..
+! #vpath %.man ..
+! #old way:
+! #VPATH = ..
+--- 103,108 ----
+ INSTALL = install
+
+ # If you are building in a subdirectory:
+! vpath %.c $(PREFIX)/bin
+! vpath %.h $(PREFIX)/bin
+! vpath %.man $(PREFIX)/share/man
+diff -c xtrs-4.9-new/main.c xtrs-4.9/main.c
+*** xtrs-4.9-new/main.c Sun Apr 14 07:03:43 2002
+--- xtrs-4.9/main.c Wed May 22 15:26:27 2002
+***************
+*** 26,32 ****
+ #include "trs_disk.h"
+ #include "load_cmd.h"
+
+! int trs_model = 1;
+ int trs_paused = 1;
+ int trs_autodelay = 0;
+ char *program_name;
+--- 26,32 ----
+ #include "trs_disk.h"
+ #include "load_cmd.h"
+
+! int trs_model = 5;
+ int trs_paused = 1;
+ int trs_autodelay = 0;
+ char *program_name;