summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-21 14:18:48 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-21 14:18:48 +0000
commit6c4f28a8c476dc992397a9662fea663af94521b0 (patch)
tree61c5907fc85c3700bfa4731e02ad838d2dfeea8d /app-emulation
parentAdding categories to dependencies. See bug 45110 for details. (diff)
downloadhistorical-6c4f28a8c476dc992397a9662fea663af94521b0.tar.gz
historical-6c4f28a8c476dc992397a9662fea663af94521b0.tar.bz2
historical-6c4f28a8c476dc992397a9662fea663af94521b0.zip
This ebuild was incorrectly placed in the basiliskII directory. It is a fork of the basiliskII project and not portable to other archs like basiliskII is.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/basiliskII-jit/ChangeLog11
-rw-r--r--app-emulation/basiliskII-jit/Manifest4
-rw-r--r--app-emulation/basiliskII-jit/basiliskII-jit-1.0.0.ebuild89
-rw-r--r--app-emulation/basiliskII-jit/files/digest-basiliskII-jit-1.0.01
-rw-r--r--app-emulation/basiliskII-jit/metadata.xml6
-rw-r--r--app-emulation/basiliskII/Manifest7
6 files changed, 115 insertions, 3 deletions
diff --git a/app-emulation/basiliskII-jit/ChangeLog b/app-emulation/basiliskII-jit/ChangeLog
new file mode 100644
index 000000000000..3172943aa69e
--- /dev/null
+++ b/app-emulation/basiliskII-jit/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emulation/basiliskII-jit
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII-jit/ChangeLog,v 1.1 2004/03/21 14:18:48 dholm Exp $
+
+*basiliskII-jit-1.0.0 (21 Mar 2004)
+
+ 21 Mar 2004; David Holm <dholm@gentoo.org> basiliskII-jit-1.0.0.ebuild,
+ metadata.xml:
+ This ebuild was incorrectly placed in the basiliskII directory. I have moved
+ it here since it is a fork of basiliskII and not the same project.
+
diff --git a/app-emulation/basiliskII-jit/Manifest b/app-emulation/basiliskII-jit/Manifest
new file mode 100644
index 000000000000..5d1beb644f6b
--- /dev/null
+++ b/app-emulation/basiliskII-jit/Manifest
@@ -0,0 +1,4 @@
+MD5 a4cd4dad9337be117231f091218f7e96 basiliskII-jit-1.0.0.ebuild 2697
+MD5 facc0dd047834a48c927393cabd0cc37 metadata.xml 518
+MD5 46881f0f53b945f4d78fe739d6605012 ChangeLog 513
+MD5 1cbb0fab815fa2bc2c502966bdf62294 files/digest-basiliskII-jit-1.0.0 79
diff --git a/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0.ebuild b/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0.ebuild
new file mode 100644
index 000000000000..696945f95d25
--- /dev/null
+++ b/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0.ebuild,v 1.1 2004/03/21 14:18:48 dholm Exp $
+
+inherit flag-o-matic
+
+### This package requires a Mac II/Classic ROM, A Mac OS Image
+### Mac OS 7.5.3r2 is available freely from the Apple Homepage
+### System ROMS can be retreived from a 'real' Mac, See info/man pages
+
+S="${WORKDIR}/BasiliskII-jit-1.0/src/Unix"
+DESCRIPTION="BasiliskII Macintosh Emulator"
+HOMEPAGE="http://gwenole.beauchesne.online.fr/basilisk2/"
+SRC_URI="http://hometown.aol.de/wimdk/files/BasiliskII-jit-1.0-mdk-src.tar.bz2"
+
+LICENSE="GPL-2 | LGPL-2.1"
+KEYWORDS="x86 -ppc"
+SLOT="0"
+
+IUSE="X gtk xv esd dga"
+
+### fbdev support in the stable release... the cvs branch is broken, period!
+### gtk and esd support are compile time options, we'll check the usual
+### use variables here and set ./configure options accordingly
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ esd? ( media-sound/esound )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix up the vendor (bug 35352)
+ sed -i \
+ -e "s/Mandrake/Gentoo/g" ${S}/keycodes || \
+ die "sed keycods failed"
+}
+
+src_compile() {
+ #fpu_x86 doesnt compile properly if -O3 or greater :(
+ replace-flags -O[3-9] -O2
+
+ local myflags
+
+### Default ./configure options are all =yes by default. we'll check for
+### and use -values and switch them accordingly
+
+ use X || myflags="${myflags} --with-x=no"
+ use esd || myflags="${myflags} --with-esd=no"
+ use gtk || myflags="${myflags} --with-gtk=no"
+ use dga || myflags="${myflags} --with-dga=no"
+ use xv || myflags="${myflags} --enable-xf86-vidmode=no"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-jit-compiler \
+ ${myflags} || die "./configure failed"
+
+ #hack to link against libstdc++ for gcc3.x compatibility
+ sed -i \
+ -e 's:-o $(OBJ_DIR)/gencpu:-lstdc++ -o $(OBJ_DIR)/gencpu:' \
+ Makefile || die "sed Makefile failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+
+ cd ../..
+ dodoc ChangeLog INSTALL README TECH TODO TODO.JIT
+
+### Networking is _disabled_ in this revision, hopefully -r2 will
+### resolve the permissions issue / linux src compilation problem
+### that prevents it's inclusion
+
+### Uncomment the following, and read the manual _carefully_ if you really
+### need networking, this will create a sheep_net.o kernel module that
+### provides (effectivly) an ethernet bridge between basliskII and the kernel
+
+# make modules
+}
diff --git a/app-emulation/basiliskII-jit/files/digest-basiliskII-jit-1.0.0 b/app-emulation/basiliskII-jit/files/digest-basiliskII-jit-1.0.0
new file mode 100644
index 000000000000..3679057027e2
--- /dev/null
+++ b/app-emulation/basiliskII-jit/files/digest-basiliskII-jit-1.0.0
@@ -0,0 +1 @@
+MD5 de61127f222213d066ac8317cb87e625 BasiliskII-jit-1.0-mdk-src.tar.bz2 597741
diff --git a/app-emulation/basiliskII-jit/metadata.xml b/app-emulation/basiliskII-jit/metadata.xml
new file mode 100644
index 000000000000..87c8da54520e
--- /dev/null
+++ b/app-emulation/basiliskII-jit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<longdescription>Basilisk II is an Open Source 680x0 Macintosh emulator developed by Christian Bauer. The Basilisk II/JIT project aims at providing a dynamically recompiling 680x0 cpu core to the original Basilisk II. This is achieved thanks to the adaptation of Bernie Meyer's excellent just-in-time (JIT) compiler for UAE to Basilisk II.</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/basiliskII/Manifest b/app-emulation/basiliskII/Manifest
index 8b05169e5ab0..eee5d4107afe 100644
--- a/app-emulation/basiliskII/Manifest
+++ b/app-emulation/basiliskII/Manifest
@@ -1,5 +1,6 @@
-MD5 25e117a8345a93bf06e353fa24df57f3 ChangeLog 1742
+MD5 f097bf19ee51b248102340d9f4f5ea50 ChangeLog 2095
MD5 55fbe64aa6bbebb7d9cf5aa7abdc7c2a basiliskII-0.9.0.ebuild 2574
-MD5 630307f369a0cd5d613a9ee4aecf6098 basiliskII-1.0.0.ebuild 2693
+MD5 53062b17bc63eab61e30867d93446703 metadata.xml 454
+MD5 af90268afadb78562ae9ae7906941fa4 basiliskII-1.0.0_pre20020115.ebuild 2613
MD5 d45a6f9ac5136a79e49778d98cf973b8 files/digest-basiliskII-0.9.0 75
-MD5 1cbb0fab815fa2bc2c502966bdf62294 files/digest-basiliskII-1.0.0 79
+MD5 8d473aa97b40ed58727e0e364223a39c files/digest-basiliskII-1.0.0_pre20020115 75