summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-08-01 20:51:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-08-01 20:51:36 +0000
commitb106e468f6dd8777ab5762145900d64a43957829 (patch)
tree0ab7e3f990f5dec4f9dfcd2cfebf9f92df3a4a50 /app-emulation
parentinitial commit (bug 24821) (diff)
downloadhistorical-b106e468f6dd8777ab5762145900d64a43957829.tar.gz
historical-b106e468f6dd8777ab5762145900d64a43957829.tar.bz2
historical-b106e468f6dd8777ab5762145900d64a43957829.zip
initial commit (bug 24821)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gens/Manifest3
-rw-r--r--app-emulation/gens/files/digest-gens-2.121
-rw-r--r--app-emulation/gens/gens-2.12.ebuild45
3 files changed, 48 insertions, 1 deletions
diff --git a/app-emulation/gens/Manifest b/app-emulation/gens/Manifest
index 424b55282bf7..b84b0a272d81 100644
--- a/app-emulation/gens/Manifest
+++ b/app-emulation/gens/Manifest
@@ -1,2 +1,3 @@
-MD5 09105e35604d9615a782dc155d9cdd59 gens-2.12.ebuild 836
+MD5 0e74791dc8505d300034f3c30587fbad gens-2.12.ebuild 991
+MD5 c2e18790e48e3f3cc7c956e97e5618a3 ChangeLog 397
MD5 efe989e52031e5386fc937649c0fdffa files/digest-gens-2.12 62
diff --git a/app-emulation/gens/files/digest-gens-2.12 b/app-emulation/gens/files/digest-gens-2.12
new file mode 100644
index 000000000000..82219b967387
--- /dev/null
+++ b/app-emulation/gens/files/digest-gens-2.12
@@ -0,0 +1 @@
+MD5 84b7511333f796633cfd0465c17679f2 Gens212a1SrcL.zip 572647
diff --git a/app-emulation/gens/gens-2.12.ebuild b/app-emulation/gens/gens-2.12.ebuild
new file mode 100644
index 000000000000..06806bcdd8d7
--- /dev/null
+++ b/app-emulation/gens/gens-2.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gens/gens-2.12.ebuild,v 1.1 2003/08/01 20:51:33 msterret Exp $
+
+inherit games
+
+S="${WORKDIR}/${PN}_linux/gens"
+DESCRIPTION="A Sega Genesis/CD/32X emulator"
+SRC_URI="mirror://sourceforge/gens/Gens212a1SrcL.zip"
+HOMEPAGE="http://gens.consolemul.com/"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2
+ app-arch/unzip
+ >=dev-lang/nasm-0.98
+ >=sys-apps/sed-4
+ >=x11-libs/gtk+-2.0*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:\./resource:${GAMES_DATADIR}/${P}:" g_ddraw_dummy.cpp || \
+ die "sed g_ddraw_dummy.cpp failed"
+
+ sed -i \
+ -e "s:\./resource:${GAMES_DATADIR}/${P}:" g_main_dummy.cpp || \
+ die "sed g_main_dummy.cpp failed"
+}
+
+src_install () {
+ dogamesbin gens
+
+ insinto ${GAMES_DATADIR}/${P}
+ doins resource/*
+
+ # Install documentation.
+ dodoc ../README
+
+ prepgamesdirs
+}