summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-17 03:11:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-17 03:11:35 +0000
commitc5e1bb24527f8fe40d1d672cca6c10cceefb0c8e (patch)
tree116ac6d02490fc79f905906033211219a224f562 /app-emulation
parentpushing 0.6.2 keywording forward to 0.6.5 (diff)
downloadhistorical-c5e1bb24527f8fe40d1d672cca6c10cceefb0c8e.tar.gz
historical-c5e1bb24527f8fe40d1d672cca6c10cceefb0c8e.tar.bz2
historical-c5e1bb24527f8fe40d1d672cca6c10cceefb0c8e.zip
old
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/files/digest-wine-200503101
-rw-r--r--app-emulation/wine/wine-20050310.ebuild130
2 files changed, 0 insertions, 131 deletions
diff --git a/app-emulation/wine/files/digest-wine-20050310 b/app-emulation/wine/files/digest-wine-20050310
deleted file mode 100644
index 9cf471077c5a..000000000000
--- a/app-emulation/wine/files/digest-wine-20050310
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d90d31716ba71211af26ac773934f57e Wine-20050310.tar.gz 11798040
diff --git a/app-emulation/wine/wine-20050310.ebuild b/app-emulation/wine/wine-20050310.ebuild
deleted file mode 100644
index aa2711f54cfc..000000000000
--- a/app-emulation/wine/wine-20050310.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.7 2005/04/07 22:59:51 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
-HOMEPAGE="http://www.winehq.com/"
-SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
- arts? ( kde-base/arts )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- gif? ( media-libs/giflib )
- jpeg? ( media-libs/jpeg )
- glut? ( virtual/glut )
- lcms? ( media-libs/lcms )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-soundlibs
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- sys-devel/bison
- doc? ( app-text/docbook-sgml-utils app-text/jadetex )
- sys-devel/flex"
-
-pkg_setup() {
- if use amd64 ; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- else
- export ABI=x86
- fi
- fi
-}
-
-src_unpack() {
- unpack Wine-${PV}.tar.gz
- cd "${S}"
-
- epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
-
- test_flag -fstack-protector && epatch "${FILESDIR}"/20041019-no-stack.patch #66002
-}
-
-config_cache() {
- local h ans="no"
- use ${1} && ans="yes"
- shift
- for h in "$@" ; do
- export ac_cv_${h}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- config_cache jack header_jack_jack_h
- config_cache cups header_cups_cups_h
- config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
- use arts || export ARTSCCONFIG="/bin/false"
- config_cache nas header_audio_audiolib_h header_audio_soundlib_h
- config_cache gif header_gif_lib_h
- config_cache glut lib_glut_glutMainLoop
- config_cache jpeg header_jpeglib_h
- config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
- config_cache lcms header_lcms_h
-
- strip-flags
- use lcms && append-flags -I${ROOT}/usr/include/lcms
-
- if ! built_with_use app-text/docbook-sgml-utils tetex ; then
- export DB2PDF=true
- export DB2PS=true
- fi
-
- # $(use_enable amd64 win64)
- # USE=debug is broken in this release
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- $(use_enable debug trace) \
- $(use_enable debug) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
- if use doc ; then
- emake -j1 -C documentation doc || die "docs"
- fi
-}
-
-src_install() {
- make \
- prefix="${D}"/usr \
- bindir="${D}"/usr/bin \
- datadir="${D}"/usr/share \
- includedir="${D}"/usr/include/wine \
- sysconfdir="${D}"/etc/wine \
- mandir="${D}"/usr/share/man \
- libdir="${D}"/usr/$(get_libdir) \
- dlldir="${D}"/usr/$(get_libdir)/wine \
- install || die
- use doc && dodoc documentation/*.pdf
-
- insinto /usr/share/wine
- doins documentation/samples/config || die "doins config"
-
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
-}