summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-08-29 05:51:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-08-29 05:51:36 +0000
commit3f6901c75d4f3433dcb5a0738ddb763ffe1d9364 (patch)
tree1b7a63a0ed4dbc51d73b3f06255a0d833b9e43f7 /app-forensics/libewf/libewf-20140608.ebuild
parentVersion bump. (diff)
downloadhistorical-3f6901c75d4f3433dcb5a0738ddb763ffe1d9364.tar.gz
historical-3f6901c75d4f3433dcb5a0738ddb763ffe1d9364.tar.bz2
historical-3f6901c75d4f3433dcb5a0738ddb763ffe1d9364.zip
Bump
Package-Manager: portage-2.2.12/cvs/Linux x86_64
Diffstat (limited to 'app-forensics/libewf/libewf-20140608.ebuild')
-rw-r--r--app-forensics/libewf/libewf-20140608.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-forensics/libewf/libewf-20140608.ebuild b/app-forensics/libewf/libewf-20140608.ebuild
new file mode 100644
index 000000000000..1c25e2a86a03
--- /dev/null
+++ b/app-forensics/libewf/libewf-20140608.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20140608.ebuild,v 1.1 2014/08/29 05:51:25 patrick Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://code.google.com/p/libewf/"
+SRC_URI="https://googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python unicode"
+IUSE="bfio debug ewf +fuse +ssl static-libs +uuid unicode zlib"
+
+DEPEND="
+ sys-libs/zlib
+ bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
+ fuse? ( sys-fs/fuse )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable unicode wide-character-type)
+ $(use_with zlib)
+ # autodetects bzip2 but does not use
+ --without-bzip2
+ $(use_with bfio libbfio)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}