summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-09-12 07:04:48 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-09-12 07:04:48 +0000
commit61826f2e04cc2fc18cdb2d59ba19919668962869 (patch)
treeb5ca4790919036259055641ef4c90118919d120b /app-forensics/rkhunter/rkhunter-1.1.5.ebuild
parentMoved app-admin/chkrootkit to app-forensics/chkrootkit (diff)
downloadhistorical-61826f2e04cc2fc18cdb2d59ba19919668962869.tar.gz
historical-61826f2e04cc2fc18cdb2d59ba19919668962869.tar.bz2
historical-61826f2e04cc2fc18cdb2d59ba19919668962869.zip
Moved from app-admin/rkhunter to app-forensics/rkhunter.
Diffstat (limited to 'app-forensics/rkhunter/rkhunter-1.1.5.ebuild')
-rw-r--r--app-forensics/rkhunter/rkhunter-1.1.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-forensics/rkhunter/rkhunter-1.1.5.ebuild b/app-forensics/rkhunter/rkhunter-1.1.5.ebuild
new file mode 100644
index 000000000000..045dfb10ae5b
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.1.5.ebuild,v 1.1 2004/09/12 07:04:48 dragonheart Exp $
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://www.rootkit.nl/"
+SRC_URI="http://downloads.rootkit.nl/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~alpha ~amd64 ~sparc"
+IUSE=""
+S=${WORKDIR}/${PN}
+DEPEND="app-arch/tar
+ app-arch/gzip
+ virtual/mta"
+RDEPEND="app-shells/bash
+ dev-lang/perl"
+
+src_install() {
+ cd ${S}/files
+ dodir /usr/lib/rkhunter
+ dodir /usr/lib/rkhunter/db
+ insinto /usr/lib/rkhunter/db
+ doins *.dat
+ dodir /usr/lib/rkhunter/scripts
+ exeinto /usr/lib/rkhunter/scripts
+ doexe *.pl check_update.sh
+ insinto /etc
+ doins rkhunter.conf
+ dosed "s:#DBDIR=/usr/local/rkhunter/db:DBDIR=/usr/lib/rkhunter/db\nINSTALLDIR=/usr:g" /etc/rkhunter.conf
+ exeinto /usr/bin
+ doexe rkhunter
+ dodoc CHANGELOG LICENSE README WISHLIST
+
+ exeinto /etc/cron.daily
+ newexe ${FILESDIR}/rkhunter.cron rkhunter
+}
+
+pkg_postinst() {
+ echo
+ einfo "A cron script has been installed to /etc/cron.daily/rkhunter."
+ einfo "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ einfo "directions."
+ echo
+}
+
+pkg_prerm() {
+ rm -rf /usr/lib/rkhunter/tmp
+}