summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-12-04 03:40:31 +0000
committerMamoru Komachi <usata@gentoo.org>2005-12-04 03:40:31 +0000
commit69c8186e430dc31a0a966aa9f10e271263c99139 (patch)
treef01e606357a590153b1631711dbfdc2854c3fa6c /app-i18n/qimhangul/qimhangul-0.0.3.ebuild
parentVersion bumped. Marked 0.9.12 stable on x86. Thanks to Jeongsu Kim <jeongsu@b... (diff)
downloadhistorical-69c8186e430dc31a0a966aa9f10e271263c99139.tar.gz
historical-69c8186e430dc31a0a966aa9f10e271263c99139.tar.bz2
historical-69c8186e430dc31a0a966aa9f10e271263c99139.zip
Version bumped. Added a patch to fix 3-bul keyboard users. Thanks to Kim SeongCheol <kseongcheol@yahoo.com>; bug #103471.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'app-i18n/qimhangul/qimhangul-0.0.3.ebuild')
-rw-r--r--app-i18n/qimhangul/qimhangul-0.0.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/qimhangul/qimhangul-0.0.3.ebuild b/app-i18n/qimhangul/qimhangul-0.0.3.ebuild
new file mode 100644
index 000000000000..19fbd72fc6f9
--- /dev/null
+++ b/app-i18n/qimhangul/qimhangul-0.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/qimhangul-0.0.3.ebuild,v 1.1 2005/12/04 03:40:31 usata Exp $
+
+inherit qt3
+
+DESCRIPTION="Korean input method plugin for Qt immodules"
+HOMEPAGE="http://kldp.net/projects/qimhangul/"
+SRC_URI="http://kldp.net/frs/download.php/2907/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.3.4)"
+
+pkg_setup() {
+ if [ ! -e /usr/qt/3/plugins/inputmethods/libqimsw-none.so ] ; then
+ die "You need to rebuild >=x11-libs/qt-3.3.3-r1 with immqt-bc or immqt USE flag enabled."
+ fi
+}
+
+src_compile() {
+ ${QTDIR}/bin/qmake -makefile || die "qmake failed"
+ emake -j1 || die "make failed."
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ einfo
+ einfo "After you emerged ${PN}, use right click to switch immodules for Qt."
+ einfo "If you would like to use qimhangul as default instead of XIM,"
+ einfo " set QT_IM_MODULE to hangul2."
+ einfo "e.g.)"
+ einfo " % export QT_IM_MODULE=hangul2"
+ einfo
+ ewarn
+ ewarn "qtconfig is no longer used for selecting input methods."
+ ewarn
+}