summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-07-18 06:49:30 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-07-18 06:49:30 +0000
commit9faf5a2d5ec5d6a3b8f2a79082158ee692915732 (patch)
treeaa46704b87bb10dd59f8a9fed6b6c4eddcdda573 /app-i18n/x-unikey/x-unikey-1.0.ebuild
parentAdded depenency on app-emulation/emul-linux-x86-soundlibs for alsa support. (diff)
downloadhistorical-9faf5a2d5ec5d6a3b8f2a79082158ee692915732.tar.gz
historical-9faf5a2d5ec5d6a3b8f2a79082158ee692915732.tar.bz2
historical-9faf5a2d5ec5d6a3b8f2a79082158ee692915732.zip
Stable on x86, Bumped to 1.0
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-i18n/x-unikey/x-unikey-1.0.ebuild')
-rw-r--r--app-i18n/x-unikey/x-unikey-1.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/x-unikey/x-unikey-1.0.ebuild b/app-i18n/x-unikey/x-unikey-1.0.ebuild
new file mode 100644
index 000000000000..ad6211879000
--- /dev/null
+++ b/app-i18n/x-unikey/x-unikey-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-1.0.ebuild,v 1.1 2005/07/18 06:49:30 pclouds Exp $
+
+inherit eutils
+
+DESCRIPTION="Vietnamese X Input Method"
+HOMEPAGE="http://unikey.sourceforge.net/linux.php"
+SRC_URI="mirror://sourceforge/unikey/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls gtk"
+
+DEPEND="virtual/x11
+ nls? ( sys-devel/gettext )
+ gtk? ( >=x11-libs/gtk+-2.2 )"
+
+src_compile() {
+ local myconf
+ # --with-gtk-sysconfdir to prevent sandbox violation only
+ use gtk && myconf="--with-unikey-gtk --with-gtk-sysconfdir=${D}/etc/gtk-2.0"
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ if use gtk;then
+ dodir etc/gtk-2.0
+ make DESTDIR=${D} install -C src/unikey-gtk
+ fi
+ dobin src/xim/ukxim src/gui/unikey
+ insinto /etc/env.d
+ doins ${FILESDIR}/01x-unikey
+ dodoc doc/manual doc/ukmacro doc/unikeyrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Go to /etc/env.d/01x-unikey and uncomment appropriate lines"
+ einfo "to enable x-unikey"
+ einfo ""
+ if use gtk; then
+ gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
+ einfo "If you want to use x-unikey as the default gtk+ input method,"
+ einfo "change GTK_IM_MODULE in /etc/env.d/01x-unikey to \"unikey\""
+ einfo ""
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
+ fi
+}