summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-01-26 12:46:13 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-01-26 12:46:13 +0000
commitdfb404a92ccb894c7c297bf536902660ce224d6e (patch)
tree80d1f38f1f6174a8cf2d6bd70ae5fd795039db01 /app-i18n
parentversion bump. added -fPIC for amd64 systems (bug #45755). enabled gpilot plug... (diff)
downloadhistorical-dfb404a92ccb894c7c297bf536902660ce224d6e.tar.gz
historical-dfb404a92ccb894c7c297bf536902660ce224d6e.tar.bz2
historical-dfb404a92ccb894c7c297bf536902660ce224d6e.zip
version bump.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-6125.ebuild68
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-61251
4 files changed, 78 insertions, 2 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index 9bfc1e09b34a..3d6a7b7f9c7d 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.61 2005/01/06 14:50:58 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.62 2005/01/26 12:46:13 hattya Exp $
+
+*anthy-ss-6125 (26 Jan 2005)
+
+ 26 Jan 2005; Akinori Hattori <hattya@gentoo.org> +anthy-ss-6125.ebuild:
+ version bump.
06 Jan 2005; Akinori Hattori <hattya@gentoo.org> -anthy-ss-5818.ebuild,
-anthy-ss-5822.ebuild:
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 6a11585c0bb2..bd3e5e2a2609 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,9 +1,11 @@
-MD5 fffc4d0590d1caebe0d770a07ffb080f ChangeLog 8076
+MD5 eba38462b4bdfa685c63d491b64800d2 ChangeLog 8197
MD5 948b23be091fde144693d8c0add073e8 anthy-ss-5911.ebuild 1517
MD5 bb9eb18d91aeeb59506a244890e9078c anthy-ss-5924.ebuild 1517
MD5 bb9850aca38be64e684ef0a018f60976 anthy-ss-6024.ebuild 1513
+MD5 dd2a3763fb5b3cfe366f94dda08fbb3c anthy-ss-6125.ebuild 1513
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 bac116c2499963cb3b710d1b844b240c files/digest-anthy-ss-5911 63
MD5 0b077af94ae9cd4b1a942c308187a306 files/digest-anthy-ss-5924 63
MD5 72302f8477a04967cb0cbc0c19fb5902 files/digest-anthy-ss-6024 63
+MD5 9600fdfa7b132c1942a74e968b209f2e files/digest-anthy-ss-6125 63
diff --git a/app-i18n/anthy-ss/anthy-ss-6125.ebuild b/app-i18n/anthy-ss/anthy-ss-6125.ebuild
new file mode 100644
index 000000000000..3bf49efd2a02
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-6125.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-6125.ebuild,v 1.1 2005/01/26 12:46:13 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/13135/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-6125 b/app-i18n/anthy-ss/files/digest-anthy-ss-6125
new file mode 100644
index 000000000000..268978f8e3f9
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-6125
@@ -0,0 +1 @@
+MD5 34de9d766d8a049ced489c482840e75d anthy-6125.tar.gz 1918633