summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-10-22 02:57:21 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-10-22 02:57:21 +0000
commit63162d03ed43c7dfdc7b150cd5971f165d163ca3 (patch)
treedb3470b30cf39f15335b32d3de9c8bf56bd5770e /app-laptop/macosd
parentMarked stable x86 (diff)
downloadhistorical-63162d03ed43c7dfdc7b150cd5971f165d163ca3.tar.gz
historical-63162d03ed43c7dfdc7b150cd5971f165d163ca3.tar.bz2
historical-63162d03ed43c7dfdc7b150cd5971f165d163ca3.zip
Version bump
Diffstat (limited to 'app-laptop/macosd')
-rw-r--r--app-laptop/macosd/ChangeLog8
-rw-r--r--app-laptop/macosd/Manifest7
-rw-r--r--app-laptop/macosd/files/digest-macosd-0.1.91
-rw-r--r--app-laptop/macosd/macosd-0.1.9.ebuild46
-rw-r--r--app-laptop/macosd/metadata.xml23
5 files changed, 82 insertions, 3 deletions
diff --git a/app-laptop/macosd/ChangeLog b/app-laptop/macosd/ChangeLog
index 6133a726bdcc..8eb7b8622586 100644
--- a/app-laptop/macosd/ChangeLog
+++ b/app-laptop/macosd/ChangeLog
@@ -1,5 +1,11 @@
# ChangeLog for app-laptop/macosd
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.1 2004/09/25 00:07:58 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.2 2004/10/22 02:57:21 fafhrd Exp $
+
+*macosd-0.1.9 (21 Oct 2004)
+
+ 21 Oct 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +macosd-0.1.9.ebuild:
+ Version bump; added metadata.xml
25 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> : New ebuild #55485
diff --git a/app-laptop/macosd/Manifest b/app-laptop/macosd/Manifest
index 341aa154d3f8..23b942286221 100644
--- a/app-laptop/macosd/Manifest
+++ b/app-laptop/macosd/Manifest
@@ -1,4 +1,7 @@
-MD5 4009d9eb928ff19d39accdd3010e5961 ChangeLog 288
MD5 86539016af97446c30e3d5fd8838fd7f macosd-0.1.7.ebuild 1210
-MD5 43cd825ea802fb0841d757bb667229cf files/macosd-0.1.7-include-fix.diff 1068
+MD5 92817b348e97a3bc191a34efc720d358 ChangeLog 443
+MD5 abe393841d214276e4b23cfd319e289c macosd-0.1.9.ebuild 1271
+MD5 185c57b922f3a6264b9421ce45f098f5 metadata.xml 1045
MD5 b06e205ccef0f87bc5dca70acf5e99a7 files/digest-macosd-0.1.7 65
+MD5 43cd825ea802fb0841d757bb667229cf files/macosd-0.1.7-include-fix.diff 1068
+MD5 1dcb5edab66af7f0a128b77c7d2b09b8 files/digest-macosd-0.1.9 65
diff --git a/app-laptop/macosd/files/digest-macosd-0.1.9 b/app-laptop/macosd/files/digest-macosd-0.1.9
new file mode 100644
index 000000000000..617fe2d364b9
--- /dev/null
+++ b/app-laptop/macosd/files/digest-macosd-0.1.9
@@ -0,0 +1 @@
+MD5 fde5ab8145fea6d348644176758e2341 macosd-0.1.9.tar.bz2 166308
diff --git a/app-laptop/macosd/macosd-0.1.9.ebuild b/app-laptop/macosd/macosd-0.1.9.ebuild
new file mode 100644
index 000000000000..512781f29633
--- /dev/null
+++ b/app-laptop/macosd/macosd-0.1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/macosd-0.1.9.ebuild,v 1.1 2004/10/22 02:57:21 fafhrd Exp $
+
+inherit eutils
+
+DESCRIPTION="On-Screen-Display frontend for pbbuttonsd (only for PPC Laptops)."
+HOMEPAGE="http://www.exactcode.de/oss/macosd/"
+SRC_URI="http://dl.rocklinux-consulting.de/oss/macosd/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+DEPEND="virtual/x11
+ >=app-laptop/pbbuttonsd-0.5.2-r1
+ >=x11-libs/evas-1.0.0.20040529_pre13
+ >=x11-libs/xosd-2.2.5"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ # can't use econf -- this packages uses ROCK Linux style configure
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-xosd \
+ --with-evas || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/macosd
+ dodir /usr/bin
+ einstall || die
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Make sure that pbbuttons is running (add it to your default runlevel)"
+ einfo "and then add the following to your ~/.xinitrc to have macosd"
+ einfo "start whenever you launch X:"
+ einfo "macosd -t CleanOSX &"
+ einfo "To see a listing of available themes, run: macosd -l"
+}
+
diff --git a/app-laptop/macosd/metadata.xml b/app-laptop/macosd/metadata.xml
new file mode 100644
index 000000000000..6b82857d562c
--- /dev/null
+++ b/app-laptop/macosd/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>fafhrd@gentoo.org</email>
+</maintainer>
+<longdescription>
+from the webpage...
+
+For PowerPC laptops such as the iBooks and PowerBooks a special daemon named pbbuttonsd can handle the special "multi-media" keys to dim the display and regulate the audio volume accordingly.
+
+However I find the example Gtk+ application gtkpbbuttons not that pretty.
+
+So I implemented a more On-Screen-Display like variant. Currently it can utilize the XOSD library.
+
+Although recently that other program got some pixmap theming support, it is still written in "handling every bit manually C" and still uses Gtk+.
+
+The latest MacOSD deos now utilze the anti-aliasing and real alpha blending canvas library Evas. It does utilize gtkpbbuttons themes just fine - and comes with a slightly cleaned-up version CleanOSX
+
+MacOSD is licensed under the terms of the GPL v2.
+</longdescription>
+</pkgmetadata>