summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-12 21:20:16 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-12 21:20:16 +0000
commit1efbbb39ef4b633b718bd886adce8cda1c7f4033 (patch)
treefbd5045e47d93858f08e9927c39ec6493d941e07 /app-misc/jpilot
parentclosed bug #422 (diff)
downloadhistorical-1efbbb39ef4b633b718bd886adce8cda1c7f4033.tar.gz
historical-1efbbb39ef4b633b718bd886adce8cda1c7f4033.tar.bz2
historical-1efbbb39ef4b633b718bd886adce8cda1c7f4033.zip
jpilot 0.99.2
Diffstat (limited to 'app-misc/jpilot')
-rw-r--r--app-misc/jpilot/ChangeLog12
-rw-r--r--app-misc/jpilot/files/digest-jpilot-0.99.23
-rw-r--r--app-misc/jpilot/jpilot-0.99.2.ebuild68
3 files changed, 82 insertions, 1 deletions
diff --git a/app-misc/jpilot/ChangeLog b/app-misc/jpilot/ChangeLog
index 863f395829fe..22068964f319 100644
--- a/app-misc/jpilot/ChangeLog
+++ b/app-misc/jpilot/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-misc/jpilot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/ChangeLog,v 1.1 2002/02/01 21:53:08 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/ChangeLog,v 1.2 2002/02/12 21:20:16 blocke Exp $
+
+*jpilot-0.99.2 (12 Feb 2002)
+
+ 12 Feb 2002; Bruce A. Locke <blocke@shivan.org> ChangeLog :
+
+ Added 0.99.2 with updated malsync plugin and cleaned up ebuild
+
+ PLEASE NOTE: reliable USB support with jpilot and other packages
+ is dependent on having a CVS snapshot of pilot-link that is not
+ source compatible with packages such as GNOME's Pilot support.
*jpilot-0.99-r2 (1 Feb 2002)
diff --git a/app-misc/jpilot/files/digest-jpilot-0.99.2 b/app-misc/jpilot/files/digest-jpilot-0.99.2
new file mode 100644
index 000000000000..f7044397a308
--- /dev/null
+++ b/app-misc/jpilot/files/digest-jpilot-0.99.2
@@ -0,0 +1,3 @@
+MD5 57be9e7cd2b2878fd439c98d77d4bdb9 jpilot-0.99.2.tar.gz 864763
+MD5 a35a50c05950b27cb2eda07bf9d4f5cb jpilot-syncmal_0.62.2.tar.gz 125580
+MD5 962702319e49618b2dced101572b41e8 malsync_2.0.7.src.tar.gz 173957
diff --git a/app-misc/jpilot/jpilot-0.99.2.ebuild b/app-misc/jpilot/jpilot-0.99.2.ebuild
new file mode 100644
index 000000000000..98dd3c945f53
--- /dev/null
+++ b/app-misc/jpilot/jpilot-0.99.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.2.ebuild,v 1.1 2002/02/12 21:20:16 blocke Exp $
+
+SYNCMAL="0.62.2"
+MALSYNC="2.0.7"
+A="${P}.tar.gz jpilot-syncmal_${SYNCMAL}.tar.gz malsync_${MALSYNC}.src.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+SRC_URI="http://jpilot.org/${P}.tar.gz http://www.tomw.org/malsync/malsync_${MALSYNC}.src.tar.gz http://people.atl.mediaone.net/jasonday/code/syncmal/jpilot-syncmal_${SYNCMAL}.tar.gz"
+HOMEPAGE="http://jpilot.org/"
+
+# In order to use the malsync plugin you'll need to refer to the homepage
+# for jpilot-syncmal http://people.atl.mediaone.net/jasonday/code/syncmal/
+# And you'll also need an avangto account.
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4 >=dev-libs/pilot-link-0.9.5"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ unpack jpilot-syncmal_${SYNCMAL}.tar.gz
+ cd ${S}/jpilot-syncmal_${SYNCMAL}
+ unpack malsync_${MALSYNC}.src.tar.gz
+}
+
+src_compile() {
+
+ if [ -z "`use nls`" ] ; then
+ NLS_OPTION="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr --host=${CHOST} ${NLS_OPTION} || die
+
+ # make sure we use $CFLAGS
+ mv Makefile Makefile.old
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
+
+ emake || die
+
+ # build malsync plugin
+ cd ${S}/jpilot-syncmal_${SYNCMAL}
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install() {
+
+ # work around for broken Makefile
+ dodir /usr/bin
+
+ make prefix=${D}/usr install
+
+ insinto /usr/lib/jpilot/plugins
+ doins jpilot-syncmal_${SYNCMAL}/.libs/libsyncmal.so
+
+ dodoc README TODO UPGRADING ABOUT-NLS BUGS CHANGELOG COPYING \
+ CREDITS INSTALL
+ doman docs/*.1
+
+ newdoc jpilot-syncmal_${SYNCMAL}/ChangeLog ChangeLog.jpilot-syncmal
+ newdoc jpilot-syncmal_${SYNCMAL}/README README.jpilot-syncmal
+ dodoc jpilot-syncmal_${SYNCMAL}/malsync/Doc/README_AvantGo
+ dodoc jpilot-syncmal_${SYNCMAL}/malsync/Doc/README_malsync
+
+}
+