summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-06-03 17:19:14 +0000
committerAlin Năstac <mrness@gentoo.org>2006-06-03 17:19:14 +0000
commit40b1a97d8267659d46e766a9b8f839eba02db53c (patch)
treeafa83b64074096f00260122099283946855e4f06 /app-mobilephone/obexftp
parentdon't unpack the patch twice (diff)
downloadhistorical-40b1a97d8267659d46e766a9b8f839eba02db53c.tar.gz
historical-40b1a97d8267659d46e766a9b8f839eba02db53c.tar.bz2
historical-40b1a97d8267659d46e766a9b8f839eba02db53c.zip
Detect and make use of SDP support only when bluetooth USE flag is enabled (#135344).
Package-Manager: portage-2.0.54-r2
Diffstat (limited to 'app-mobilephone/obexftp')
-rw-r--r--app-mobilephone/obexftp/ChangeLog7
-rw-r--r--app-mobilephone/obexftp/Manifest11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch44
-rw-r--r--app-mobilephone/obexftp/obexftp-0.21.ebuild8
4 files changed, 62 insertions, 8 deletions
diff --git a/app-mobilephone/obexftp/ChangeLog b/app-mobilephone/obexftp/ChangeLog
index 2c67993f2d06..e37bfd16b280 100644
--- a/app-mobilephone/obexftp/ChangeLog
+++ b/app-mobilephone/obexftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/obexftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.11 2006/06/02 18:57:17 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.12 2006/06/03 17:19:14 mrness Exp $
+
+ 03 Jun 2006; Alin Nastac <mrness@gentoo.org>
+ +files/obexftp-0.21-sdp-detection.patch, obexftp-0.21.ebuild:
+ Detect and make use of SDP support only when bluetooth USE flag is enabled
+ (#135344).
*obexftp-0.21 (02 Jun 2006)
diff --git a/app-mobilephone/obexftp/Manifest b/app-mobilephone/obexftp/Manifest
index aa006dc46990..b22389656d18 100644
--- a/app-mobilephone/obexftp/Manifest
+++ b/app-mobilephone/obexftp/Manifest
@@ -1,20 +1,21 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 51b437c2c28e3267c7d1b05de4556a63 ChangeLog 5735
+MD5 29d3c890c399b8b68d754ce97a068de4 ChangeLog 5937
MD5 580f449983ce97b01d8306c9056e93b6 files/digest-obexftp-0.18 64
MD5 17cef382b7d9b74a67a45e34fbbcb81e files/digest-obexftp-0.19-r1 64
MD5 46ce676213c444e0965a46f92c2521bc files/digest-obexftp-0.21 65
MD5 6a6fe66463cf754e0bffe6c432546d25 files/obexftp-0.19-cobex_write.patch 2292
MD5 22ff2b0139e04ee668962537a486e8ab files/obexftp-0.21-cobex_write.patch 2292
+MD5 e2616e4310097497d957a6655bab7cbf files/obexftp-0.21-sdp-detection.patch 1014
MD5 1a820f941ddbd683086de6d92efbdf5c metadata.xml 336
MD5 8da2275ebba1a9f714b77ff81bebc309 obexftp-0.18.ebuild 1167
MD5 1fe0be310f8b162b9fecf3ee4ae975f4 obexftp-0.19-r1.ebuild 1295
-MD5 bbf6ab4877fbf68adad1fa0f727583ca obexftp-0.21.ebuild 1293
+MD5 57d29039b4e1e91c67ee52442663607a obexftp-0.21.ebuild 1375
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
-iD8DBQFEgIoZjG8pv1lIUX4RAokGAKCeANz/q2dSIU6YmVPCS1rdBKX7DQCgm8rd
-W2dpW70O/3qx7J8P7VfAYLE=
-=fcEO
+iD8DBQFEgcSnjG8pv1lIUX4RAv1DAKDlxgkV61Y1Okok5wOFppUzU1eBUgCaAzD3
+dwzq5Sl44hK0JW1yHfIMrcU=
+=pIYi
-----END PGP SIGNATURE-----
diff --git a/app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch b/app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch
new file mode 100644
index 000000000000..c1cb7f183feb
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch
@@ -0,0 +1,44 @@
+diff -Nru obexftp-0.21.orig/apps/obexftp_sdp.c obexftp-0.21/apps/obexftp_sdp.c
+--- obexftp-0.21.orig/apps/obexftp_sdp.c 2006-06-03 20:02:27.529609000 +0300
++++ obexftp-0.21/apps/obexftp_sdp.c 2006-06-03 20:03:26.753310250 +0300
+@@ -34,6 +34,8 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
++#ifdef HAVE_SDPLIB
++
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/sdp.h>
+ #include <bluetooth/sdp_lib.h>
+@@ -173,3 +175,17 @@
+ return 0;
+ }
+ */
++
++#else
++
++void obexftp_sdp_unregister(void)
++{
++}
++
++int obexftp_sdp_register(void)
++{
++ syslog(LOG_ERR, "SDP not supported.");
++ return -1;
++}
++
++#endif // HAVE_SDPLIB
+diff -Nru obexftp-0.21.orig/configure.in obexftp-0.21/configure.in
+--- obexftp-0.21.orig/configure.in 2006-06-03 20:02:27.529609000 +0300
++++ obexftp-0.21/configure.in 2006-06-03 20:00:45.000000000 +0300
+@@ -27,7 +27,9 @@
+ AM_ICONV
+ dnl IRDA_CHECK
+ BLUETOOTH_CHECK
+-SDPLIB_CHECK
++if test $am_cv_bluetooth_found = yes; then
++ SDPLIB_CHECK
++fi
+ USB_CHECK
+
+ # check for optional swig rebuild
diff --git a/app-mobilephone/obexftp/obexftp-0.21.ebuild b/app-mobilephone/obexftp/obexftp-0.21.ebuild
index bcc716536ebe..e4c45c62129b 100644
--- a/app-mobilephone/obexftp/obexftp-0.21.ebuild
+++ b/app-mobilephone/obexftp/obexftp-0.21.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.21.ebuild,v 1.1 2006/06/02 18:57:18 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.21.ebuild,v 1.2 2006/06/03 17:19:14 mrness Exp $
-inherit perl-module flag-o-matic eutils
+inherit eutils perl-module flag-o-matic autotools
DESCRIPTION="File transfer over OBEX for mobile phones"
SRC_URI="http://triq.net/obexftp/${P}.tar.bz2"
@@ -24,6 +24,10 @@ src_unpack() {
unpack ${A}
epatch "${FILESDIR}/${P}-cobex_write.patch"
+ epatch "${FILESDIR}/${P}-sdp-detection.patch"
+
+ cd "${S}"
+ eautoreconf
}
src_compile() {